summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-02 16:02:06 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-02 16:03:13 +0200
commit68ad618dd7e3e84190f9071b205cc7d811665a0e (patch)
treefd1aaabb6d70f5cf4426ce10be162e8401347665 /dev-python
parentdev-python/docstring-to-markdown: add github upstream metadata (diff)
downloadgentoo-68ad618dd7e3e84190f9071b205cc7d811665a0e.tar.gz
gentoo-68ad618dd7e3e84190f9071b205cc7d811665a0e.tar.bz2
gentoo-68ad618dd7e3e84190f9071b205cc7d811665a0e.zip
dev-python/chardet: add 5.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/chardet/Manifest1
-rw-r--r--dev-python/chardet/chardet-5.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index a5f2cf28032c..8a149e1d6f07 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1 +1,2 @@
DIST chardet-5.0.0.gh.tar.gz 2016879 BLAKE2B 006992a4945840b3720e93f932618cf81debc094a3ae353bfdd4e56ecdc5a01e4a250bed15473d8d59108978fdbfb769081a9b87f672d35f4892d5ba04c2deb5 SHA512 d19413a4f1f571f3627ec3f55dcc6a69497f6a1d72fe972051713f4d7a473cd539cfbce2eb2c7a070295aa640c6ac2aec6fc0064751e465311935c0e4d88061a
+DIST chardet-5.1.0.gh.tar.gz 2067545 BLAKE2B 92fd916884ecd562a3ad51c58848430d1b5acad0841a410f316be4346e4c2198e5c27ce5af8639a06d6472ece6807dd2618f4a50760e77925c994d13619d290e SHA512 531888329979d229f3e966a428d14feb4612df5b71e3dff3ee3358ecbc964af95370e4c03aacecea0941d11840a16b2b12814ea8af977ff81a5abbec41d983cd
diff --git a/dev-python/chardet/chardet-5.1.0.ebuild b/dev-python/chardet/chardet-5.1.0.ebuild
new file mode 100644
index 000000000000..1a0f32883fb2
--- /dev/null
+++ b/dev-python/chardet/chardet-5.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="
+ https://github.com/chardet/chardet/
+ https://pypi.org/project/chardet/
+"
+SRC_URI="
+ https://github.com/chardet/chardet/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # super flaky test
+ # https://github.com/chardet/chardet/issues/256
+ test.py::test_detect_all_and_detect_one_should_agree
+)