summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-11 06:01:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-11 06:19:57 +0200
commit704b7c78cba908af2cc349263eff69f90a53f06b (patch)
tree89754b3e1ac40901130336274f55bc94b1129441 /dev-python
parentprofiles: Last rites: dev-php/pear and dependencies (diff)
downloadgentoo-704b7c78cba908af2cc349263eff69f90a53f06b.tar.gz
gentoo-704b7c78cba908af2cc349263eff69f90a53f06b.tar.bz2
gentoo-704b7c78cba908af2cc349263eff69f90a53f06b.zip
dev-python/oct2py: Bump to 5.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oct2py/Manifest1
-rw-r--r--dev-python/oct2py/oct2py-5.7.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
index eaba7f3c8e9e..1c9a4b22b90c 100644
--- a/dev-python/oct2py/Manifest
+++ b/dev-python/oct2py/Manifest
@@ -1,2 +1,3 @@
DIST oct2py-5.6.0.tar.gz 437965 BLAKE2B e22aca80608e1132f2cb8936e9dac7c97bd8e5463b6997dd80f0ed567af2a59a28b4c58995b11e2c1a970bc0bde81afda432d8ce5306b2eb5417b1f75b8b4b19 SHA512 d5eae408812358e48c9a72e823dc06a7556c09176170def00c53aacba75c6568357afe8e9a079c02e08c88ee1e7f1aa4284508471680b5542894745b19e7af36
DIST oct2py-5.6.1.tar.gz 440686 BLAKE2B 5255b0413a655f74db243d8d3a338a8468400af0c392a7ae5c6ac894edd8fa526acda5c8dbad7c5d8414dc9de3f4fa8c4aa055a396238464556186edd9500b1b SHA512 2485c7434666f8d580396759024e4f807c6e14f5d0f30a0f2449373488735c6ee91b6a8bdde8d951e0371790cd7673710986f6e3b6af0c77b3a36e92bb1c1285
+DIST oct2py-5.7.0.tar.gz 441233 BLAKE2B 601eadd10898d4b522c23d3df86aef26b2783cdb66f3942ddb568c65d828aea1a4e82c755e547ac1940c4fc449856c955b0f9931488472fb63330ca2b96e31ad SHA512 fe45b421593ef0b1257d704c0d43e89425054a6fac1c784bd66ad404e0f28d328fc4a3a7f82e589d43c2860e95a6a6b54898ef5a378362b8914f47b097c705e9
diff --git a/dev-python/oct2py/oct2py-5.7.0.ebuild b/dev-python/oct2py/oct2py-5.7.0.ebuild
new file mode 100644
index 000000000000..482fbfd11055
--- /dev/null
+++ b/dev-python/oct2py/oct2py-5.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
+ >=dev-python/octave-kernel-0.34.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.17[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )"
+
+EPYTEST_DESELECT=(
+ # No graphics toolkit available: 743589
+ "oct2py/ipython/tests/test_octavemagic.py::OctaveMagicTest::test_octave_plot"
+)
+
+distutils_enable_sphinx docs/source \
+ dev-python/numpydoc \
+ dev-python/pydata-sphinx-theme \
+ dev-python/myst-parser \
+ dev-python/sphinxcontrib-spelling
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}