summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-12 06:28:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-12 06:28:19 +0200
commit7e731074c1bb4d5c46706c45c4103eff6ee681c8 (patch)
treeaf63664267cd6f475a9c663eaef66aa8e7c39a89 /dev-python
parentdev-libs/libretls: Bump to 3.8.1 (diff)
downloadgentoo-7e731074c1bb4d5c46706c45c4103eff6ee681c8.tar.gz
gentoo-7e731074c1bb4d5c46706c45c4103eff6ee681c8.tar.bz2
gentoo-7e731074c1bb4d5c46706c45c4103eff6ee681c8.zip
dev-python/pytest-localserver: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-localserver/Manifest1
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index e0ce75d5a8c1..19e2d0a4d22c 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1 +1,2 @@
DIST pytest-localserver-0.8.0.tar.gz 28368 BLAKE2B 87e5491f442c7bfbbdd219f9f559b775dca5272dc9f92c2f8155eaa192b3192331d4c0d08877cc149624173bb1b249fd9271fe193b1ba2ba28dcab7eda8eb99c SHA512 d4e34d8bde3470dbdd7cc3e40f2b88c4d21095c2c43a4bf7452934bc0afa273946282b732924b2fed34b3a9f25ecb170a28c771cbae4d44a0f707090fb7502f1
+DIST pytest-localserver-0.8.1.tar.gz 29088 BLAKE2B 9872d9992a7a19af03bfd7fe748c42cee1daaf7789d4984582c901471eaeab7f1bcf5c21f8eed364c71805fe776f1e4053c6044cd00c333d213ef523b6d0bac4 SHA512 d0707d70b3c5caf346c7461cfca203f903277458596839cc2b1d1d48b6d1e6252e51ebcb9c21dc28fd3b98ce8368cb38e771c2a4226a5fc1dec4007f0b243cc2
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild
new file mode 100644
index 000000000000..f7374f4e1937
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-localserver/
+ https://pypi.org/project/pytest-localserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)
+
+src_prepare() {
+ # remove aiosmtpd dep
+ sed -e '/aiosmtpd/d' -i setup.py || die
+ distutils-r1_src_prepare
+}