summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-11 17:50:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-11 18:49:30 +0200
commit965783c7bf64b1478ec4e02b70650255c3347536 (patch)
treee6820eff044b2d0ff836e2fb9cc2e7ee614966ab /dev-python
parentsys-cluster/rdma-core: add slot operator to perl dep (diff)
downloadgentoo-965783c7bf64b1478ec4e02b70650255c3347536.tar.gz
gentoo-965783c7bf64b1478ec4e02b70650255c3347536.tar.bz2
gentoo-965783c7bf64b1478ec4e02b70650255c3347536.zip
dev-python/jupyter-client: Bump to 8.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter-client/Manifest1
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index 8b1f8774005a..64525fba7371 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-8.3.1.tar.gz 337007 BLAKE2B fdb0535ccda1ca13e2ead09c6df9f30c8c7d258dbfa4882a758b3923fd5bdf6afa80859f941bcc3e1a602de31c6ceef06b7a5d360d64ceab34e40de65dc65174 SHA512 ce600985ed9d36d4a96bbed6142b46988d46ea468d8f266fd3c9a7357f60d5e2a9bddb11c912a3c137079322e4363b975c4b43b1a53e65b5d649d367a098a52d
+DIST jupyter_client-8.4.0.tar.gz 338114 BLAKE2B 9588ec5a9155d008876819f6129e18799e78692056344f49556ca2aa815c2c22472520661527bdbbce6d8458cc34b01ef900d89939f1de667745e48e7a5ed4f5 SHA512 0853e15b68e4fe5d9b4811e664eb25e900ebc908902c8527f01f761f012ddb6aa928e825bd67894dbed8c62dc643d5451da0cc5907847839c832e49e15eb6027
diff --git a/dev-python/jupyter-client/jupyter-client-8.4.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.4.0.ebuild
new file mode 100644
index 000000000000..13fe78be87b6
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)