summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 05:29:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-24 06:21:12 +0100
commitf0bb0fe98de727db5cff09e490cb70cb49d7aa9a (patch)
tree7214ce73285d263f27ec307aee80f5f497ed76da /dev-python
parentdev-python/botocore: Bump to 1.29.98 (diff)
downloadgentoo-f0bb0fe98de727db5cff09e490cb70cb49d7aa9a.tar.gz
gentoo-f0bb0fe98de727db5cff09e490cb70cb49d7aa9a.tar.bz2
gentoo-f0bb0fe98de727db5cff09e490cb70cb49d7aa9a.zip
dev-python/boto3: Bump to 1.26.98
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.98.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f13edbb01006..96d3f96b9560 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.26.94.gh.tar.gz 617861 BLAKE2B 908b40868735038810cf75c903bbc8bad00a
DIST boto3-1.26.95.gh.tar.gz 623665 BLAKE2B d1d979210e22d4d39eff7148711be28ceb80b26409567c1d23f67a523667276c3a6b2a79519f89bed6d72c8cd4c8a9e04ad886805de51605c1fefcf45cebd08b SHA512 0147714fc05e5b8cab29ac66d9701fc3f64623f84a800597478133dd20f3637f15471a8cd63fc88820a7229b425843731e00470eb66106cdf525da5ce0ff3091
DIST boto3-1.26.96.gh.tar.gz 624075 BLAKE2B 6603922e29464733f0e2c59f7df5b5ca9d0092e69ab9d70bb64248ccc6c522a543ec14a480b62aeaaf26b3802867ded3ce054bb5caa37a0bd909e805cce6c422 SHA512 db5740b305d667028c0724555575d7ca21afa4f7ae634159dd5379d3907539964068120eb4011184ab63749302884a8ad4cd80fc0de9d69fd01c6f64ab3ee379
DIST boto3-1.26.97.gh.tar.gz 624442 BLAKE2B dc9097ae0aa58968d554126d44a6ed9320a62ad53c133bf5c28d44bae8215d6c4b4b0a7740834e22aae229b6103e8f28853b957dac863c6da5638bb37a5ef56e SHA512 b1be47759205ac9e2559d4bfb70a96f55f54ce384e64f8af10d2a63022ef2eae99499059a32f773f994b02a2d5a498436f2619a39eca96067c867941aec4485e
+DIST boto3-1.26.98.gh.tar.gz 625624 BLAKE2B df4222d342acd51785150b5ec96c40e7b730636ec57bc4c825ad7d1b5a3e1daf9fe70accdcba171a0c8d3027ee7d24c44ba8f36c325d275bcdd8bcc1ab04f59d SHA512 2fc1bce20ba0b6300f2dd9836188eac448d26ec07c00064ea5e62dfbe0f90ef39e3732f23242699d447d98982cbcaf5e257a7e6a80b9c0b945256ebedde88c61
diff --git a/dev-python/boto3/boto3-1.26.98.ebuild b/dev-python/boto3/boto3-1.26.98.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.98.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}