summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-17 05:27:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-17 05:33:26 +0200
commitf53832bad811ccf13a5b2154a8e7afd3eaf958c9 (patch)
tree47beef4af6a8754fb22470791239d5adbed6441d /dev-python
parentdev-python/Faker: Bump to 18.9.0 (diff)
downloadgentoo-f53832bad811ccf13a5b2154a8e7afd3eaf958c9.tar.gz
gentoo-f53832bad811ccf13a5b2154a8e7afd3eaf958c9.tar.bz2
gentoo-f53832bad811ccf13a5b2154a8e7afd3eaf958c9.zip
dev-python/starlette: Bump to 0.27.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.27.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 7615367a8973..e842ca57d2ae 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1 +1,2 @@
DIST starlette-0.26.1.gh.tar.gz 2837634 BLAKE2B bfaef7cf0826cbb4ec133e47ae918a1021fd2fe1e7048651f72f6fdcba49a80ec53bff1d63cfa56cf9e075ea58f62db0a5fab4ccfd80463a69f79e26eabc8c03 SHA512 2974b778481f6a701e8697a7a48dad33cbb8569acc5e3bf123769c3f6380d6aa5730aff3e1ba4978eee025d2479e11c731b669e58e08e16f6870225ed813d42b
+DIST starlette-0.27.0.gh.tar.gz 2838346 BLAKE2B 25f30e83edc12fa6607ef31b2711ee2b3c205aa62cc362d4a7389d61e48fc4410610841caca2e99dd3527eb0f47fe2740c5908ab5c72158e57a384563b53328d SHA512 dd7ce57b78a5ab42e62699e6feed735c66aa64dce2004304a139957c75192cc0b3a475e80bb9ecee16093940d45f142f83e61af6fad0f320a8f586fea752049f
diff --git a/dev-python/starlette/starlette-0.27.0.ebuild b/dev-python/starlette/starlette-0.27.0.ebuild
new file mode 100644
index 000000000000..757c33f915b1
--- /dev/null
+++ b/dev-python/starlette/starlette-0.27.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest