summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-09 06:43:42 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-10 06:25:02 -0500
commitd519e0ecfb408e50e11f6f3c592a2e9d521c3395 (patch)
tree3f593fb8ffc2ba45ac6d66c6b05ac5622313e2cc /dev-qt/qt-creator
parentdev-qt/qttools: migrate live to llvm-r1, allow slot 18 (diff)
downloadgentoo-d519e0ecfb408e50e11f6f3c592a2e9d521c3395.tar.gz
gentoo-d519e0ecfb408e50e11f6f3c592a2e9d521c3395.tar.bz2
gentoo-d519e0ecfb408e50e11f6f3c592a2e9d521c3395.zip
dev-qt/qt-creator: migrate live to llvm-r1, allow slot 18
Tested with 18.1.0_rc2 at same time, seems to be fine so may as well do this now. Will migrate 12.0.2 when add Qt6.6.2 given that will trigger a rebuild either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qt-creator')
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index a2c7444d9223..4587a1c7c566 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -3,8 +3,10 @@
EAPI=8
+LLVM_COMPAT=( {15..18} )
+LLVM_OPTIONAL=1
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake flag-o-matic llvm python-any-r1 readme.gentoo-r1 xdg
+inherit cmake flag-o-matic llvm-r1 python-any-r1 readme.gentoo-r1 xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -35,9 +37,9 @@ IUSE="
+clang +designer doc +help qmldesigner serialterminal
+svg test +tracing webengine
"
+REQUIRED_USE="clang? ( ${LLVM_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-LLVM_MAX_SLOT=17
QT_PV=6.2.0:6 # IDE_QT_VERSION_MIN
# := is used where Qt's private APIs are used for safety
@@ -47,7 +49,7 @@ COMMON_DEPEND="
>=dev-qt/qtdeclarative-${QT_PV}=
clang? (
dev-cpp/yaml-cpp:=
- <sys-devel/clang-$((LLVM_MAX_SLOT+1)):=
+ $(llvm_gen_dep 'sys-devel/clang:${LLVM_SLOT}')
)
designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
help? (
@@ -84,13 +86,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-12.0.0-musl-no-malloc-trim.patch
)
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
pkg_setup() {
python-any-r1_pkg_setup
- use clang && llvm_pkg_setup
+ use clang && llvm-r1_pkg_setup
}
src_prepare() {