summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-20 08:24:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:02 -0400
commit3f8d3f4f338349230bcae00d4405ef4e34495f96 (patch)
tree9645ffad379daf47704618ebc8856b918392afd0 /dev-qt/qtlocation
parentdev-qt/qt5compat: use -j1 for tests (qt6) (diff)
downloadgentoo-3f8d3f4f338349230bcae00d4405ef4e34495f96.tar.gz
gentoo-3f8d3f4f338349230bcae00d4405ef4e34495f96.tar.bz2
gentoo-3f8d3f4f338349230bcae00d4405ef4e34495f96.zip
dev-qt/qtlocation: skip broken test, do not install test files (qt6)
Broken test could be worked around with a symlink, but feel it is not really worth extra ebuild churn. wrt test files, if someone knows a sane way to stop Qt6 from installing these (this happens with almost every components, but eclass deletes tests/ by default at least), please tell me. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/qtlocation-6.5.2.ebuild26
-rw-r--r--dev-qt/qtlocation/qtlocation-6.5.9999.ebuild26
-rw-r--r--dev-qt/qtlocation/qtlocation-6.9999.ebuild26
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-6.5.2.ebuild b/dev-qt/qtlocation/qtlocation-6.5.2.ebuild
index 0ada78b606c3..2a7a4cc0389c 100644
--- a/dev-qt/qtlocation/qtlocation-6.5.2.ebuild
+++ b/dev-qt/qtlocation/qtlocation-6.5.2.ebuild
@@ -18,3 +18,29 @@ RDEPEND="
=dev-qt/qtshadertools-${PV}*:6
"
DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtlocation/qtlocation-6.5.9999.ebuild b/dev-qt/qtlocation/qtlocation-6.5.9999.ebuild
index 0ada78b606c3..2a7a4cc0389c 100644
--- a/dev-qt/qtlocation/qtlocation-6.5.9999.ebuild
+++ b/dev-qt/qtlocation/qtlocation-6.5.9999.ebuild
@@ -18,3 +18,29 @@ RDEPEND="
=dev-qt/qtshadertools-${PV}*:6
"
DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtlocation/qtlocation-6.9999.ebuild b/dev-qt/qtlocation/qtlocation-6.9999.ebuild
index 0ada78b606c3..2a7a4cc0389c 100644
--- a/dev-qt/qtlocation/qtlocation-6.9999.ebuild
+++ b/dev-qt/qtlocation/qtlocation-6.9999.ebuild
@@ -18,3 +18,29 @@ RDEPEND="
=dev-qt/qtshadertools-${PV}*:6
"
DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}