summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-01-05 16:56:58 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-01-06 00:38:56 +0200
commit338d2100cfd1329fe8fcbb2d9e7f1a8f948368be (patch)
treeba4ae42bb2a8e801f9339f9532c7a1b189a659ca /dev-qt/qtwayland
parentdev-qt/qtnetworkauth: add 6.4.2 (diff)
downloadgentoo-338d2100cfd1329fe8fcbb2d9e7f1a8f948368be.tar.gz
gentoo-338d2100cfd1329fe8fcbb2d9e7f1a8f948368be.tar.bz2
gentoo-338d2100cfd1329fe8fcbb2d9e7f1a8f948368be.zip
dev-qt/qtwayland: add 6.4.2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-6.4.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 48d101abb736..aa9f9047fb3c 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -3,3 +3,4 @@ DIST qtwayland-5.15.7-gentoo-kde-2.tar.xz 43720 BLAKE2B b80db3b4113ea2b80709595a
DIST qtwayland-5.15.7-gentoo-kde-3.tar.xz 44552 BLAKE2B bbe009f17546d975a128e68a604da853d74ce840ead2952ee465a7b4a43f8e2c6392079e73da14b184119e0f47f10293628a6fcf4115b4b19879cce592c01a1f SHA512 ed49d4cf724afd9819ffcda9a0c25aba96f422d72d3e172b882683cf650a01966a032ae1241e3bc7258717515ddc6f9b240003ec8886d5a01b2cf4f1d0c856b6
DIST qtwayland-everywhere-opensource-src-5.15.7.tar.xz 568024 BLAKE2B ed2031ea40c5618c2390865807ef33eae42a3231098f1959f0a7e9e3b8e8d70f4461647aaa11afeade0528aa4d14049b03cc566552a13dd4d1b5773ec3d16061 SHA512 a004a82ec2b4f132d597ae3c82b4079671ecdfeed09c455073e552197da2b9f921c85bef2b40be76e87e61d5ec1e7ab39ed232be26b27d9aed6e938c659965a3
DIST qtwayland-everywhere-src-6.4.0.tar.xz 836088 BLAKE2B 3efc506e1a0bc63182397d483bf352e21d39c75a7360ee3fe839527451950875748aea5cf62207ffef38b845a12c2bbbefde918d14333d1b194a4ea39b82670f SHA512 745fcc84c936c3f2fa7382291b5013679f9e57d6c680f1d352b0a132ba7cbaaea1495211f8fc4f1af85a81c711794987e4e05284d3ac06c94e92e9b601dae924
+DIST qtwayland-everywhere-src-6.4.2.tar.xz 836720 BLAKE2B d8a6b84712081097775f083f3887c18eb001fd2beba32b2abc930ec3b932f6f19b347fe2fde3b98f35c1e7e31661974b13468fb176e73bdf557a330c80d847fd SHA512 29d3f3e7fade666bcd3145106f1d782122ac3fcf94811d25917c9f45af0dc8cddb3c2149545344d91e86f86490029555758ed2e180f241703251c22c7ec15122
diff --git a/dev-qt/qtwayland/qtwayland-6.4.2.ebuild b/dev-qt/qtwayland/qtwayland-6.4.2.ebuild
new file mode 100644
index 000000000000..b1250c60de99
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-6.4.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="dev-util/wayland-scanner"
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtbase-${PV}*[gui,opengl]
+ =dev-qt/qtdeclarative-${PV}*
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"