summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-06 17:14:26 +0100
committerSam James <sam@gentoo.org>2022-10-06 17:15:26 +0100
commitb9bfff99769df96416c910d095b414c76386bd02 (patch)
treeb80acca7dfc0ad8684efcc29c4c6586ede3f3d71 /dev-qt/qtwebengine
parentdev-lang/rust: fix has_version default-libcxx test for Clang (diff)
downloadgentoo-b9bfff99769df96416c910d095b414c76386bd02.tar.gz
gentoo-b9bfff99769df96416c910d095b414c76386bd02.tar.bz2
gentoo-b9bfff99769df96416c910d095b414c76386bd02.zip
dev-qt/qtwebengine: fix has_version default-libcxx test for Clang
We moved the flag to sys-devel/clang-common to prepare for proper config file support (which is backported to 15.0.2, although it's going to be better in 16.x). Go for the hack for now, but keep the bug open as we want to switch to the proper link test from the LLVM ebuilds. Bug: https://bugs.gentoo.org/875641 Bug: https://bugs.gentoo.org/875563 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild
index b1d2486b0259..2e0e639465d3 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.5_p20220618.ebuild
@@ -200,8 +200,10 @@ src_prepare() {
fi
# src/3rdparty/gn fails with libc++ due to passing of `-static-libstdc++`
- if tc-is-clang && has_version 'sys-devel/clang[default-libcxx]'; then
- eapply "${FILESDIR}/${PN}-5.15.2_p20210521-clang-libc++.patch"
+ if tc-is-clang ; then
+ if has_version 'sys-devel/clang[default-libcxx(-)]' || has_version 'sys-devel/clang-common[default-libcxx(-)]' ; then
+ eapply "${FILESDIR}/${PN}-5.15.2_p20210521-clang-libc++.patch"
+ fi
fi
if use system-ffmpeg && has_version '>=media-video/ffmpeg-5'; then