summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 03:08:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 03:25:49 -0400
commit746ca3b3c2c45a63e5fc07fe3b2e6891caf8ff8a (patch)
tree769fd01cdeb3ca18df2b6338f5fd94b031a8a9eb /dev-qt
parentdev-qt/qtlanguageserver: add 6.7.3 (diff)
downloadgentoo-746ca3b3c2c45a63e5fc07fe3b2e6891caf8ff8a.tar.gz
gentoo-746ca3b3c2c45a63e5fc07fe3b2e6891caf8ff8a.tar.bz2
gentoo-746ca3b3c2c45a63e5fc07fe3b2e6891caf8ff8a.zip
dev-qt/qtlocation: add 6.7.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.7.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index d9439e6f30e5..554e1c53f5f7 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,6 +1,7 @@
DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.14.tar.xz 6549056 BLAKE2B 831c7091a7b9d1355121f7e1e89f62c8aaa8819bef98c80f90b1521eea9c11a35452557c97d1dd49d13e0e810bd70f5038f8682f6ac42b68622cd269664eadd3 SHA512 5a6271d61bb9ede80b8483e784d8cc15170cf3f7b019472b2362c742e1e1fd52d811c2132b751574dacee6f7274b81e6049b8a3dc934ba7612c0aef6643062dd
DIST qtlocation-everywhere-src-6.7.2.tar.xz 3166188 BLAKE2B ca22bc51308b5f5b28f96bedd4190ad747bd335790ec0975e1dc381d8fdacf720907a9842ec01cdd1add3d56549d4c096021731ea3268423d3288e1b24c993a6 SHA512 d7b8d4b9c99247362747d2d8fcf9207e710bed70c320d5c38e6868760cfe5ae2a158d1c0496af939a3e0d74369a86673cddfb25096ff8dda8dc209fd0df94e21
+DIST qtlocation-everywhere-src-6.7.3.tar.xz 3166232 BLAKE2B be9833355f758c6a7ffc799c911262c841f3419691a37a3ec21d3a2f2ffead23e69fce09811a8071c9454070659f7ea8a81eeb7ee5d7cfd89e5d76889649d8f6 SHA512 e905001e5edd4aa6fc3e28e7d9e0461083706510ae652bb8329a3eb9d0ca6a8cbea75ded54538e35a1a9389d743a41a4d1834f29184d398bdbb1281c0f4f591a
DIST qtlocation-everywhere-src-6.8.0-rc.tar.xz 3166424 BLAKE2B 699154eed09300456919f7d38e193f3300d139db4da3cf62040dbd53e23e215e867b3c9caa93c41d75ce9b8523ae5efa0a7cef8d4ebda94c05a2423703e92ee8 SHA512 eda861755631921df241cbb659f92a400413c71f382fc41c9a8d1a9c4c0f83cd1c5afdf071113236f09c847b3c5593ebe63445bf4b6e393f275220f4d6a5ca40
DIST qtlocation-mapboxgl-5.15.14-35d56672.tar.gz 3726302 BLAKE2B f51c0589a06fab35ba85b3bf4ca8a1904cda5aec47b17fdf747da527d02be623a76b1af5883b33267fab825a4b5d0863ea0220f2907e98e286b40d4a0bbc82e5 SHA512 5c2ff6ab7e4382d87546a802c5603bdcec3deb7fbb836fc981292c67660514caaa6118e164d2e099d0304710035572706562ec84e4aba5ce36b01cade8b0993e
DIST qtlocation-mapboxgl-5.15.14-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-6.7.3.ebuild b/dev-qt/qtlocation/qtlocation-6.7.3.ebuild
new file mode 100644
index 000000000000..d407e2f12e54
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-6.7.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtpositioning-${PV}:6[qml]
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}