summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:49:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:19 +0200
commit68083486d377a1e7896c2f3e938c9b8357731717 (patch)
treefb7f80c931333bf1236ea94c41f512c9f87dcd3d /dev-ros/cv_bridge
parentdev-ros/image_geometry: bump eapi (diff)
downloadgentoo-68083486d377a1e7896c2f3e938c9b8357731717.tar.gz
gentoo-68083486d377a1e7896c2f3e938c9b8357731717.tar.bz2
gentoo-68083486d377a1e7896c2f3e938c9b8357731717.zip
dev-ros/cv_bridge: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/cv_bridge')
-rw-r--r--dev-ros/cv_bridge/cv_bridge-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-ros/cv_bridge/cv_bridge-9999.ebuild b/dev-ros/cv_bridge/cv_bridge-9999.ebuild
index 422225d82b4f..8280858d30ec 100644
--- a/dev-ros/cv_bridge/cv_bridge-9999.ebuild
+++ b/dev-ros/cv_bridge/cv_bridge-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -18,7 +17,9 @@ RDEPEND="
dev-ros/rosconsole
>=media-libs/opencv-3:=[contrib(+)]
dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/boostpython.patch" )