summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 10:58:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:13 +0200
commit4743565151d210bcc6255e0cdd960732069de0a9 (patch)
tree06dc4af1abfc75e45ea3c1866d4256b9e15a5637 /dev-ros/hector_map_server/hector_map_server-0.5.2.ebuild
parentdev-ros/hector_imu_tools: Bump to 0.5.2. (diff)
downloadgentoo-4743565151d210bcc6255e0cdd960732069de0a9.tar.gz
gentoo-4743565151d210bcc6255e0cdd960732069de0a9.tar.bz2
gentoo-4743565151d210bcc6255e0cdd960732069de0a9.zip
dev-ros/hector_map_server: Bump to 0.5.2.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_map_server/hector_map_server-0.5.2.ebuild')
-rw-r--r--dev-ros/hector_map_server/hector_map_server-0.5.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/hector_map_server/hector_map_server-0.5.2.ebuild b/dev-ros/hector_map_server/hector_map_server-0.5.2.ebuild
new file mode 100644
index 000000000000..c3cd30cb4ede
--- /dev/null
+++ b/dev-ros/hector_map_server/hector_map_server-0.5.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Service for retrieving the map, as well as for raycasting based obstacle queries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/hector_map_tools
+ dev-ros/hector_marker_drawing
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"