summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 18:47:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:05 +0200
commitf9c8011a63e7d92424a2bddf9973eb55e158e4d9 (patch)
treed8b11b1d7b6e263bc57cc4aa8162da83002551c9 /dev-ros/message_filters
parentdev-ros/message_filters: bump eapi (diff)
downloadgentoo-f9c8011a63e7d92424a2bddf9973eb55e158e4d9.tar.gz
gentoo-f9c8011a63e7d92424a2bddf9973eb55e158e4d9.tar.bz2
gentoo-f9c8011a63e7d92424a2bddf9973eb55e158e4d9.zip
dev-ros/message_filters: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/message_filters')
-rw-r--r--dev-ros/message_filters/Manifest2
-rw-r--r--dev-ros/message_filters/files/boost.patch26
-rw-r--r--dev-ros/message_filters/message_filters-1.14.3-r1.ebuild32
-rw-r--r--dev-ros/message_filters/message_filters-1.15.4.ebuild32
4 files changed, 0 insertions, 92 deletions
diff --git a/dev-ros/message_filters/Manifest b/dev-ros/message_filters/Manifest
index e7119a998e05..5d86517495e4 100644
--- a/dev-ros/message_filters/Manifest
+++ b/dev-ros/message_filters/Manifest
@@ -1,3 +1 @@
-DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
-DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/dev-ros/message_filters/files/boost.patch b/dev-ros/message_filters/files/boost.patch
deleted file mode 100644
index 1acc778756a8..000000000000
--- a/dev-ros/message_filters/files/boost.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
-Author: Maarten de Vries <maarten@de-vri.es>
-Date: Thu Jan 31 00:58:29 2019 +0100
-
- Remove signals from find_package(Boost COMPONENTS ...) (#1580)
-
- The packages use signals2, not signals. Only boost libraries with
- compiled code should be passed to find_package(Boost COMPONENTS ...),
- and the signals2 library has always been header only.
-
- Boost 1.69 has removed the deprecated signals library, so the otherwise
- useless but harmless `signals` component now breaks the build.
-
-diff --git a/utilities/message_filters/CMakeLists.txt b/utilities/message_filters/CMakeLists.txt
-index 5694ac57e..d2b1477ad 100644
---- a/utilities/message_filters/CMakeLists.txt
-+++ b/utilities/message_filters/CMakeLists.txt
-@@ -13,7 +13,7 @@ catkin_package(
- )
- catkin_python_setup()
-
--find_package(Boost REQUIRED COMPONENTS signals thread)
-+find_package(Boost REQUIRED COMPONENTS thread)
-
- include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
- link_directories(${catkin_LIBRARY_DIRS})
diff --git a/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild b/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
deleted file mode 100644
index c2ab8b9cdbe7..000000000000
--- a/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=utilities/${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Set of message filters which take in messages and may output those messages at a later time"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/rosconsole
- dev-ros/roscpp
- dev-libs/boost:=[threads]
- dev-ros/genpy[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
- dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/boost.patch" )
diff --git a/dev-ros/message_filters/message_filters-1.15.4.ebuild b/dev-ros/message_filters/message_filters-1.15.4.ebuild
deleted file mode 100644
index ec6cbf8434ad..000000000000
--- a/dev-ros/message_filters/message_filters-1.15.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=utilities/${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Set of message filters which take in messages and may output those messages at a later time"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/rosconsole
- dev-ros/roscpp
- dev-libs/boost:=[threads]
- dev-ros/genpy[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
- dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-PATCHES=( "${FILESDIR}/tests.patch" )