summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 16:10:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 16:33:13 +0100
commitd9af9631c957172b1724a5bc67199f65980e949b (patch)
treefc293445d835c642bdf8bcf9285a3f767aef7ce8 /dev-ros/rosapi/rosapi-0.11.13.ebuild
parentsci-electronics/gazebo: bump to 11.3.0 (diff)
downloadgentoo-d9af9631c957172b1724a5bc67199f65980e949b.tar.gz
gentoo-d9af9631c957172b1724a5bc67199f65980e949b.tar.bz2
gentoo-d9af9631c957172b1724a5bc67199f65980e949b.zip
dev-ros/rosapi: Bump to 0.11.13.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.11.13.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.11.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.11.13.ebuild b/dev-ros/rosapi/rosapi-0.11.13.ebuild
new file mode 100644
index 000000000000..fea15e810ba5
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.11.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Service calls for getting ros meta-information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbridge_library[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosnode[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"