summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-08 14:17:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-08 14:22:28 +0200
commit999c2f7d686f42945dc8fa331951a3a081595299 (patch)
tree0faa23d15907f0b74e4894b077c8a4f2620addf4 /dev-ros/roscreate/roscreate-1.14.4.ebuild
parentdev-ros/rosclean: Bump to 1.14.4. (diff)
downloadgentoo-999c2f7d686f42945dc8fa331951a3a081595299.tar.gz
gentoo-999c2f7d686f42945dc8fa331951a3a081595299.tar.bz2
gentoo-999c2f7d686f42945dc8fa331951a3a081595299.zip
dev-ros/roscreate: Bump to 1.14.4.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/roscreate/roscreate-1.14.4.ebuild')
-rw-r--r--dev-ros/roscreate/roscreate-1.14.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/roscreate/roscreate-1.14.4.ebuild b/dev-ros/roscreate/roscreate-1.14.4.ebuild
new file mode 100644
index 000000000000..d7d38bfca154
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.14.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"