summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 16:21:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:39 +0200
commitded2915b026612cf3dc282b51d643a029f23e4b6 (patch)
tree4e6fe0ff3f676848a9f1f0a6a9dea13a0f44edb7 /dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild
parentdev-ros/rqt_gui: Bump to 0.5.2. (diff)
downloadgentoo-ded2915b026612cf3dc282b51d643a029f23e4b6.tar.gz
gentoo-ded2915b026612cf3dc282b51d643a029f23e4b6.tar.bz2
gentoo-ded2915b026612cf3dc282b51d643a029f23e4b6.zip
dev-ros/rqt_gui_cpp: Bump to 0.5.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild')
-rw-r--r--dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild
new file mode 100644
index 000000000000..b6198c787b3d
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the C++ client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ >=dev-ros/qt_gui_cpp-0.3.0
+ >=dev-ros/qt_gui-0.3.0
+ dev-ros/roscpp
+ dev-ros/nodelet
+ dev-libs/tinyxml2:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"