summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:08:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:44 +0200
commita672269ff534e46264be6c23ba9517f2d09865bc (patch)
treeeed493c9c16d27d50b85186f18434727f995977e /dev-ros/rqt_moveit
parentdev-ros/rqt_msg: Remove old (diff)
downloadgentoo-a672269ff534e46264be6c23ba9517f2d09865bc.tar.gz
gentoo-a672269ff534e46264be6c23ba9517f2d09865bc.tar.bz2
gentoo-a672269ff534e46264be6c23ba9517f2d09865bc.zip
dev-ros/rqt_moveit: bump to 0.5.9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_moveit')
-rw-r--r--dev-ros/rqt_moveit/Manifest1
-rw-r--r--dev-ros/rqt_moveit/rqt_moveit-0.5.9.ebuild25
-rw-r--r--dev-ros/rqt_moveit/rqt_moveit-9999.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-ros/rqt_moveit/Manifest b/dev-ros/rqt_moveit/Manifest
index 34bd06c3e9e1..6f6eb9688d9b 100644
--- a/dev-ros/rqt_moveit/Manifest
+++ b/dev-ros/rqt_moveit/Manifest
@@ -1,2 +1,3 @@
DIST rqt_moveit-0.5.7.tar.gz 8000 BLAKE2B 699216c0058b6e22930b4bd0459757d420415285ca5900520802889347b0256d3d8eee5f8f3a4bdbbfe45371ec607e7c9d6b3b0e3d82adbfc1d64bff0c5a4c44 SHA512 3103723389aa9ff891d245fbdf1e7eb157973dee25e4ff2530d147bf72385dcec716418db1a32ef0a2bcaf0940cfa36e95334293cc93baa1c6e6c97dabe2e403
+DIST rqt_moveit-0.5.9.tar.gz 8158 BLAKE2B 088ba6a64e642e3548f84eb48598af73d7ae2589fd3eeed129bbc2b66a120765b43adedde79dff6d5823785f4024b878d361a650d56539ac40eeec5c48cb12ec SHA512 6e177a67eafcfbc9b79c1c3dadfbeda89d5fbeebd9cc5e62da99c324feaf0a4ca77134c295c9d96afdca2d1049bee80a60c08166167b3bd8f3886c86acb4a1c9
DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 BLAKE2B 68a6643fef3c101ddbc0ae6a66d7fed3ec2fd7bc811947487946084bd6c93e564e11693941ef336b6d5428f926b0c297ccff845056e3f123320fba176ffe00cf SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51
diff --git a/dev-ros/rqt_moveit/rqt_moveit-0.5.9.ebuild b/dev-ros/rqt_moveit/rqt_moveit-0.5.9.ebuild
new file mode 100644
index 000000000000..3464f0e6ea45
--- /dev/null
+++ b/dev-ros/rqt_moveit/rqt_moveit-0.5.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_moveit"
+
+inherit ros-catkin
+
+DESCRIPTION="Assists monitoring tasks for MoveIt! motion planner"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_topic[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild b/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild
index 11c6884465d0..3464f0e6ea45 100644
--- a/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild
+++ b/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_moveit"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin