summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 07:56:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:06 +0200
commit3a9710dbd12c019c4c19bbc0df7c49927d1c384c (patch)
tree4a21a22962850ca0c198492a43fa92a161c2b182 /dev-ros/tf2/tf2-0.7.3.ebuild
parentdev-ros/test_tf2: Bump to 0.7.3. (diff)
downloadgentoo-3a9710dbd12c019c4c19bbc0df7c49927d1c384c.tar.gz
gentoo-3a9710dbd12c019c4c19bbc0df7c49927d1c384c.tar.bz2
gentoo-3a9710dbd12c019c4c19bbc0df7c49927d1c384c.zip
dev-ros/tf2: Bump to 0.7.3.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2/tf2-0.7.3.ebuild')
-rw-r--r--dev-ros/tf2/tf2-0.7.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2/tf2-0.7.3.ebuild b/dev-ros/tf2/tf2-0.7.3.ebuild
new file mode 100644
index 000000000000..1e993d3ee72a
--- /dev/null
+++ b/dev-ros/tf2/tf2-0.7.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="The second generation Transform Library in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge:=
+ dev-ros/rostime
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/roscpp dev-cpp/gtest )
+"