summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 19:01:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:14 +0200
commit6b8af759f7792e0c39c3a128494bf4cd05af69b5 (patch)
tree54f4b04262ea28b0d44dbd1d100635a8ca00e7ba /dev-ros/topic_tools
parentdev-ros/topic_tools: bump eapi (diff)
downloadgentoo-6b8af759f7792e0c39c3a128494bf4cd05af69b5.tar.gz
gentoo-6b8af759f7792e0c39c3a128494bf4cd05af69b5.tar.bz2
gentoo-6b8af759f7792e0c39c3a128494bf4cd05af69b5.zip
dev-ros/topic_tools: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/topic_tools')
-rw-r--r--dev-ros/topic_tools/Manifest2
-rw-r--r--dev-ros/topic_tools/files/yaml.patch53
-rw-r--r--dev-ros/topic_tools/topic_tools-1.14.3-r1.ebuild34
-rw-r--r--dev-ros/topic_tools/topic_tools-1.15.4.ebuild33
4 files changed, 0 insertions, 122 deletions
diff --git a/dev-ros/topic_tools/Manifest b/dev-ros/topic_tools/Manifest
index e7119a998e05..5d86517495e4 100644
--- a/dev-ros/topic_tools/Manifest
+++ b/dev-ros/topic_tools/Manifest
@@ -1,3 +1 @@
-DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
-DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/dev-ros/topic_tools/files/yaml.patch b/dev-ros/topic_tools/files/yaml.patch
deleted file mode 100644
index e783e321b7fb..000000000000
--- a/dev-ros/topic_tools/files/yaml.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 29053c4832229efa7160fb944c05e3bc82e11540 Mon Sep 17 00:00:00 2001
-From: Martijn Buijs <Martijn.buijs@gmail.com>
-Date: Tue, 23 Apr 2019 18:20:12 +0200
-Subject: [PATCH] Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
- (#1688)
-
-* Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
-
-* Change all usages of yaml.load to yaml.safe_load
-
-* Extend PyYAML's SafeLoader and use it with `yaml.load`
-
-Also added convenience functions for using this loader for reuse in
-`roslaunch`
-
-* fix typo in rosparam.yaml_load_all
-
-* Modify Loader and SafeLoader in yaml module directly
-
-* Revert whitespace change
-
-* Revert unrelated change to import through global variable construction
----
- clients/rospy/src/rospy/client.py | 2 +-
- .../test/test_roslib_message.py | 2 +-
- .../client_verification/test_slave_api.py | 2 +-
- test/test_rosparam/test/check_rosparam.py | 8 ++---
- .../check_rosparam_command_line_online.py | 2 +-
- .../check_rosservice_command_line_online.py | 4 +--
- test/test_rostopic/test/test_rostopic_unit.py | 30 +++++++++----------
- tools/rosbag/src/rosbag/bag.py | 2 +-
- tools/rosgraph/src/rosgraph/roslogging.py | 2 +-
- tools/roslaunch/src/roslaunch/loader.py | 4 +--
- .../test/unit/test_roslaunch_dump_params.py | 4 +--
- tools/rosparam/src/rosparam/__init__.py | 7 ++++-
- tools/rosservice/src/rosservice/__init__.py | 4 +--
- tools/rostopic/src/rostopic/__init__.py | 6 ++--
- tools/topic_tools/scripts/relay_field | 2 +-
- 15 files changed, 43 insertions(+), 38 deletions(-)
-
-diff --git a/tools/topic_tools/scripts/relay_field b/tools/topic_tools/scripts/relay_field
-index 6630b685d..cc73ac443 100755
---- a/tools/topic_tools/scripts/relay_field
-+++ b/tools/topic_tools/scripts/relay_field
-@@ -98,7 +98,7 @@ class RelayField(object):
- if self.input_fn is not None:
- m = self.input_fn(m)
-
-- msg_generation = yaml.load(self.expression)
-+ msg_generation = yaml.safe_load(self.expression)
- pub_args = _eval_in_dict_impl(msg_generation, None, {'m': m})
-
- now = rospy.get_rostime()
diff --git a/dev-ros/topic_tools/topic_tools-1.14.3-r1.ebuild b/dev-ros/topic_tools/topic_tools-1.14.3-r1.ebuild
deleted file mode 100644
index ecddea9d6441..000000000000
--- a/dev-ros/topic_tools/topic_tools-1.14.3-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python2_7 )
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cpp_common
- dev-ros/rosconsole
- dev-ros/roscpp
- dev-ros/rostime
- dev-ros/xmlrpcpp
-"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
- dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-PATCHES=( "${FILESDIR}/yaml.patch" )
diff --git a/dev-ros/topic_tools/topic_tools-1.15.4.ebuild b/dev-ros/topic_tools/topic_tools-1.15.4.ebuild
deleted file mode 100644
index 49f8f6d9bbb1..000000000000
--- a/dev-ros/topic_tools/topic_tools-1.15.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python2_7 )
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cpp_common
- dev-ros/rosconsole
- dev-ros/roscpp
- dev-ros/rostime
- dev-ros/xmlrpcpp
-"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
- dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
- )"