summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-27 07:51:53 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-27 13:24:49 +0200
commitcb1ba7c26b4dfe06a411da0153c5e04843c89d44 (patch)
tree42c7dd5600d81c947ca52dc3bbd9656bd42a623c /dev-ruby/coolio
parentdev-ruby/coolio: update HOMEPAGE (diff)
downloadgentoo-cb1ba7c26b4dfe06a411da0153c5e04843c89d44.tar.gz
gentoo-cb1ba7c26b4dfe06a411da0153c5e04843c89d44.tar.bz2
gentoo-cb1ba7c26b4dfe06a411da0153c5e04843c89d44.zip
dev-ruby/coolio: add ruby30
Switch to bundled iobuffer since the upstream version by the same author it no longer maintained and does not work with ruby30. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/coolio')
-rw-r--r--dev-ruby/coolio/coolio-1.7.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/coolio/coolio-1.7.1-r1.ebuild b/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..b7f9b1eec0bd
--- /dev/null
+++ b/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_NAME="cool.io"
+
+RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/cool.io/extconf.rb ext/iobuffer/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
+HOMEPAGE="https://coolio.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
+
+all_ruby_prepare() {
+ rm -r Gemfile* lib/.gitignore || die
+
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove specs that require network connectivity
+ rm -f spec/dns_spec.rb || die
+
+ # Use one address consistently
+ sed -i -e 's/localhost/127.0.0.1/' spec/{udp_socket,tcp_server,iobuffer}_spec.rb || die
+}