summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-04 06:46:25 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-04 07:29:02 +0100
commitc34420cee7aec55fb7a2555f2054a2f65df0c973 (patch)
treefe7466838cfff6d31a2b9bc1a9846f6e6aaa1eb9 /dev-ruby/google-protobuf/google-protobuf-3.11.3.ebuild
parentdev-ruby/google-protobuf: cleanup (diff)
downloadgentoo-c34420cee7aec55fb7a2555f2054a2f65df0c973.tar.gz
gentoo-c34420cee7aec55fb7a2555f2054a2f65df0c973.tar.bz2
gentoo-c34420cee7aec55fb7a2555f2054a2f65df0c973.zip
dev-ruby/google-protobuf: add 3.11.3
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/google-protobuf/google-protobuf-3.11.3.ebuild')
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.11.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.11.3.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.11.3.ebuild
new file mode 100644
index 000000000000..95bcaa6b4caa
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.11.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.7.0 )"
+
+all_ruby_prepare() {
+ sed -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^ end/ s:^:#:' \
+ -e 's:../src/protoc:protoc:' \
+ -e 's/:compile,//' \
+ -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}