summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-14 10:52:40 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-14 10:52:40 +0200
commit8c78558ffd96fe0c705083b3f2a493c850bdc303 (patch)
treee50327e1d77e4a813c2d51472feb474f2fbae87e /dev-ruby/maildir/maildir-2.2.1-r1.ebuild
parentdev-ruby/maildir: initial import of 2.2.1 (diff)
downloadgentoo-8c78558ffd96fe0c705083b3f2a493c850bdc303.tar.gz
gentoo-8c78558ffd96fe0c705083b3f2a493c850bdc303.tar.bz2
gentoo-8c78558ffd96fe0c705083b3f2a493c850bdc303.zip
dev-ruby/maildir: avoid file collisions with dev-ruby/rake
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/maildir/maildir-2.2.1-r1.ebuild')
-rw-r--r--dev-ruby/maildir/maildir-2.2.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/maildir/maildir-2.2.1-r1.ebuild b/dev-ruby/maildir/maildir-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..58a9690259b9
--- /dev/null
+++ b/dev-ruby/maildir/maildir-2.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for reading and writing arbitrary messages in DJB's maildir format"
+HOMEPAGE="https://github.com/ktheory/maildir"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/fakefs-0.3.2 dev-ruby/mail dev-ruby/shoulda-context dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e 's/shoulda/shoulda-context/' test/helper.rb || die
+
+ # Avoid tests that appear to need activesupport for .blank? support
+ sed -i -e '/add and remove flags/,/^ end/ s:^:#:' test/test_message.rb || die
+ sed -i -e '/be removed from flag list/,/^ end/ s:^:#:' test/test_maildir.rb || die
+}