summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-03 07:13:46 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-03 07:13:46 +0200
commit2d7c0519ba8eb44dd93dac4cf32e5983cdab24a1 (patch)
treebf6ffb3e3c308f6b3d0b7a3e04f5e2c7c377872d /dev-ruby/mechanize/mechanize-2.7.6.ebuild
parentdev-perl/DBD-SQLite: Bump to version 1.580.0 re bug #656546 (diff)
downloadgentoo-2d7c0519ba8eb44dd93dac4cf32e5983cdab24a1.tar.gz
gentoo-2d7c0519ba8eb44dd93dac4cf32e5983cdab24a1.tar.bz2
gentoo-2d7c0519ba8eb44dd93dac4cf32e5983cdab24a1.zip
dev-ruby/mechanize: add 2.7.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/mechanize/mechanize-2.7.6.ebuild')
-rw-r--r--dev-ruby/mechanize/mechanize-2.7.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/mechanize/mechanize-2.7.6.ebuild b/dev-ruby/mechanize/mechanize-2.7.6.ebuild
new file mode 100644
index 000000000000..b65435a33fc6
--- /dev/null
+++ b/dev-ruby/mechanize/mechanize-2.7.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc EXAMPLES.rdoc GUIDE.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library used for automating interaction with websites"
+HOMEPAGE="https://github.com/sparklemotion/mechanize"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.7
+ test? ( dev-ruby/minitest:5 )"
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.6
+ >=dev-ruby/net-http-digest_auth-1.1.1
+ >=dev-ruby/net-http-persistent-2.5.2:0
+ >=dev-ruby/ntlm-http-0.1.1
+ >=dev-ruby/webrobots-0.0.9
+ >=dev-ruby/http-cookie-1.0.2
+ >=dev-ruby/mime-types-1.17.2:*
+ >=dev-ruby/domain_name-0.5.1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}