summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-18 07:32:01 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-18 07:32:01 +0200
commit9d04a40d4c05eb1ec7c6c0d26184faa995fe12cc (patch)
tree8782bb149f88520ab774b4d7279aebef384fe908 /dev-ruby/power_assert/power_assert-1.2.0.ebuild
parentdev-ruby/combustion: add 1.2.0 (diff)
downloadgentoo-9d04a40d4c05eb1ec7c6c0d26184faa995fe12cc.tar.gz
gentoo-9d04a40d4c05eb1ec7c6c0d26184faa995fe12cc.tar.bz2
gentoo-9d04a40d4c05eb1ec7c6c0d26184faa995fe12cc.zip
dev-ruby/power_assert: add 1.2.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/power_assert/power_assert-1.2.0.ebuild')
-rw-r--r--dev-ruby/power_assert/power_assert-1.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/power_assert/power_assert-1.2.0.ebuild b/dev-ruby/power_assert/power_assert-1.2.0.ebuild
new file mode 100644
index 000000000000..ae5e41b5fc6a
--- /dev/null
+++ b/dev-ruby/power_assert/power_assert-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="power_assert.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Shows each value of variables and method calls in the expression"
+HOMEPAGE="https://github.com/ruby/power_assert"
+SRC_URI="https://github.com/ruby/power_assert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="|| ( Ruby BSD-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e '1igem "test-unit"' \
+ -e '/byebug/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid git dependency
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid circular dependency on byebug when bootstrapping ruby
+ sed -i -e '/byebug/ s:^:#:' -e '/test_core_ext_helper/ s:^:#:' test/test_helper.rb || die
+ rm test/test_core_ext_helper.rb test/trace_test.rb || die
+
+ # Avoid circular dependency on pry when bootstrapping ruby
+ sed -i -e '/pry/ s:^:#:' -e '/test_colorized_pp/,/^ end/ s:^:#:' test/block_test.rb || die
+}