summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-10 11:08:07 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-11 07:27:47 +0100
commit8d96556e369ecaf0fa440d43ffd6597a2e60256e (patch)
tree83a48d10ba9274b382d5bb67c8a7a99dc2a34eb2 /dev-ruby/public_suffix/public_suffix-5.0.1.ebuild
parentdev-ruby/psych: add 5.0.1 (diff)
downloadgentoo-8d96556e369ecaf0fa440d43ffd6597a2e60256e.tar.gz
gentoo-8d96556e369ecaf0fa440d43ffd6597a2e60256e.tar.bz2
gentoo-8d96556e369ecaf0fa440d43ffd6597a2e60256e.zip
dev-ruby/public_suffix: add 5.0.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/public_suffix/public_suffix-5.0.1.ebuild')
-rw-r--r--dev-ruby/public_suffix/public_suffix-5.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/public_suffix/public_suffix-5.0.1.ebuild b/dev-ruby/public_suffix/public_suffix-5.0.1.ebuild
new file mode 100644
index 000000000000..0e54e7908148
--- /dev/null
+++ b/dev-ruby/public_suffix/public_suffix-5.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse and decompose a domain name into top level domain, domain and subdomains"
+HOMEPAGE="https://simonecarletti.com/code/publicsuffix-ruby/"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha:1.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' \
+ -e '/yard/,/CLOBBER.include/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
+}