summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-03 08:29:05 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-03 08:29:05 +0100
commit3e55cb6b21e30501829ce623526b6e788d2ce027 (patch)
tree57d0660bdc0f875afed6677b6ad52d8fec8f1ba3 /dev-ruby/rbnacl
parentdev-ruby/net-ssh: cleanup (diff)
downloadgentoo-3e55cb6b21e30501829ce623526b6e788d2ce027.tar.gz
gentoo-3e55cb6b21e30501829ce623526b6e788d2ce027.tar.bz2
gentoo-3e55cb6b21e30501829ce623526b6e788d2ce027.zip
dev-ruby/rbnacl: import 4.0.1
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/rbnacl')
-rw-r--r--dev-ruby/rbnacl/Manifest1
-rw-r--r--dev-ruby/rbnacl/metadata.xml11
-rw-r--r--dev-ruby/rbnacl/rbnacl-4.0.1.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/Manifest b/dev-ruby/rbnacl/Manifest
new file mode 100644
index 000000000000..b9b6e98b6a9f
--- /dev/null
+++ b/dev-ruby/rbnacl/Manifest
@@ -0,0 +1 @@
+DIST rbnacl-4.0.1.gem 219648 SHA256 8161c789cf6567084b648b480e4c6081546ecea265061376f715887977ba4072 SHA512 987a3cdbaa83ee433bf8acce8c6b89202a7ae6c485a0f8bbb58b77c6c6f096fd60ec571c88cd96cabc861bc0e4fecf0611177732136a88a98a03dbb547cf6b67 WHIRLPOOL 6c53418e2b492a38b1dea30501375f893fadb64d590321cb0d1c9b0e2494adfcb3e04ddcdf7480bacd9ae26ea9af951f4ce100024bc514b4630cbf07a4486c5c
diff --git a/dev-ruby/rbnacl/metadata.xml b/dev-ruby/rbnacl/metadata.xml
new file mode 100644
index 000000000000..22da0070927f
--- /dev/null
+++ b/dev-ruby/rbnacl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cryptosphere/rbnacl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rbnacl/rbnacl-4.0.1.ebuild b/dev-ruby/rbnacl/rbnacl-4.0.1.ebuild
new file mode 100644
index 000000000000..444d5008c7a7
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-4.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/cryptosphere/rbnacl"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" dev-libs/libsodium"
+DEPEND+=" test? ( dev-libs/libsodium )"
+
+all_ruby_prepare() {
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
+}