summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-09-28 13:26:48 +0300
committerSam James <sam@gentoo.org>2021-09-28 21:51:41 +0100
commite442f457956901e411910c0080d297e30ddc32db (patch)
treec556d8ab3b1e7b4f9d038012fb5942bb9c8c1f62 /dev-ruby/rotp
parentwww-apps/redmine: update to 4.1.4 (diff)
downloadgentoo-e442f457956901e411910c0080d297e30ddc32db.tar.gz
gentoo-e442f457956901e411910c0080d297e30ddc32db.tar.bz2
gentoo-e442f457956901e411910c0080d297e30ddc32db.zip
dev-ruby/rotp: new package
Ruby One Time Password library, runtime dependency for www-apps/redmine. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/rotp')
-rw-r--r--dev-ruby/rotp/Manifest1
-rw-r--r--dev-ruby/rotp/metadata.xml19
-rw-r--r--dev-ruby/rotp/rotp-6.2.0.ebuild31
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/rotp/Manifest b/dev-ruby/rotp/Manifest
new file mode 100644
index 000000000000..69bab31e7f7f
--- /dev/null
+++ b/dev-ruby/rotp/Manifest
@@ -0,0 +1 @@
+DIST rotp-6.2.0.tar.gz 60000 BLAKE2B dba270201593425c9282aca71efb33ecacda916996ebfffc703dd865a6c6ee3b3da4098497ce036a95157089d8d736e9413d0aa9fd0dc582d4b278ce811e05d0 SHA512 938cf9feffbe7e86f542c6dde4cd87b57e2ddd2696303e69cb76bc9fb04ffb40c9a5ef45288f23cb096d9f6706e0b48ad89907dc9322594df10c8c0521feffa1
diff --git a/dev-ruby/rotp/metadata.xml b/dev-ruby/rotp/metadata.xml
new file mode 100644
index 000000000000..7d387e411d0c
--- /dev/null
+++ b/dev-ruby/rotp/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>ruby@gentoo.org</email>
+</maintainer>
+<maintainer type="person" proxied="yes">
+<email>azamat.hackimov@gmail.com</email>
+<name>Azamat H. Hackimov</name>
+</maintainer>
+<maintainer type="project" proxied="proxy">
+<email>proxy-maint@gentoo.org</email>
+<name>Proxy Maintainers</name>
+</maintainer>
+<upstream>
+<remote-id type="github">mdp/rotp</remote-id>
+<remote-id type="rubygems">rotp</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rotp/rotp-6.2.0.ebuild b/dev-ruby/rotp/rotp-6.2.0.ebuild
new file mode 100644
index 000000000000..8b16fcb7f638
--- /dev/null
+++ b/dev-ruby/rotp/rotp-6.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Ruby One Time Password Library"
+HOMEPAGE="https://github.com/mdp/rotp"
+SRC_URI="https://github.com/mdp/rotp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/openssl:0="
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/timecop-0.8 )
+"
+
+all_ruby_prepare() {
+ # Remove simplecov
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}