summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-08 15:23:36 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-08 15:23:54 +0100
commit4bb2d57fe082582e436e342cde35e74587db7423 (patch)
tree295ea024b73914dd7af7f2f80d8056b2209b29bc /dev-ruby/rspec-core
parentdev-ruby/rspec-expectations: add 3.12.4 (diff)
downloadgentoo-4bb2d57fe082582e436e342cde35e74587db7423.tar.gz
gentoo-4bb2d57fe082582e436e342cde35e74587db7423.tar.bz2
gentoo-4bb2d57fe082582e436e342cde35e74587db7423.zip
dev-ruby/rspec-core: add 3.12.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.12.3.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index a70aa6c6eb61..04c607d4024e 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -1 +1,2 @@
DIST rspec-core-3.12.2-git.tgz 409039 BLAKE2B 087b08b6a5231a050d89dc8ec1648509b47078b54c05e5effc02cfcdd0f4cae9fa85f7dc02d643a6e81eb9e4c1dca54d6f4e0b0f79a5d91072c1934fddac9169 SHA512 6ecd39355a5060dbf820b89f2f5958b7e75a185e003036cb0ceb8dd6021d79fa14495a300acdc019b55e174bf8a6be42022bfeb0f22a35c461c0f81cd1a742fd
+DIST rspec-core-3.12.3-git.tgz 409316 BLAKE2B 7d7ab38346895499403ff5ce7770f7605ebefa9ffcdb3feee4a01df27731fea3d98f22481a242f3799ff104c040312cbb7794b947b6f95ba69e8b571971e056b SHA512 d2e6ee6638dacc629e6f772840e2d384e07408e2d459dbd8c68404398df466afad9df1929b6a4e23ca10beab22b7f24efa725806bb9a6dd855adc5ad3eb17c4e
diff --git a/dev-ruby/rspec-core/rspec-core-3.12.3.ebuild b/dev-ruby/rspec-core/rspec-core-3.12.3.ebuild
new file mode 100644
index 000000000000..13e66548c64d
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-3.12.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="highlight test"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+DEPEND+="test? ( dev-vcs/git )"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-support-${SUBVERSION}*
+ highlight? ( >=dev-ruby/coderay-1.1.1 )
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ >=dev-ruby/coderay-1.1.1
+ dev-ruby/syntax
+ >=dev-ruby/thread_order-1.1.0
+ >=dev-ruby/rspec-expectations-3.8.0:3
+ >=dev-ruby/rspec-mocks-2.99.0:3
+ >=dev-ruby/rspec-support-3.9.1:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/support/aruba_support.rb || die
+ rm -f spec/integration/{bisect_runners,failed_line_detection,filtering,order,persistence_failures,suite_hooks_errors}_spec.rb || die
+ rm -f spec/integration/{spec_file_load_errors,output_stream,fail_if_no_examples}_spec.rb || die
+
+ # Avoid a spec failing due to path issues
+ sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
+ spec/rspec/core/configuration_spec.rb || die
+
+ # Avoid a spec that depends on dev-ruby/rspec to lessen circular
+ # dependencies, bug 662328
+ sed -e '/loads mocks and expectations when the constants are referenced/askip "gentoo: bug 662328"' \
+ -i spec/rspec/core_spec.rb || die
+
+ # Avoid a spec depending on specifics on local networks
+ # This fails when localhost resolves to ::1 which may be a
+ # ruby regression in the drb/acl code.
+ rm -f spec/rspec/core/bisect/server_spec.rb || die
+
+ # Avoid old regression check (already fixed upstream)
+ sed -i -e '/uses only one thread local variable/askip "old safety check"' spec/rspec/core_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
+}