summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-11 09:07:33 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-11 09:15:03 +0200
commit68a690d69bcb41ad9434937e009185ed0ca483c9 (patch)
treed1fb695f9abcfca449f540a4db5831fa4f60e845 /dev-ruby/ruby_parser
parentdev-ruby/ruby2ruby: cleanup (diff)
downloadgentoo-68a690d69bcb41ad9434937e009185ed0ca483c9.tar.gz
gentoo-68a690d69bcb41ad9434937e009185ed0ca483c9.tar.bz2
gentoo-68a690d69bcb41ad9434937e009185ed0ca483c9.zip
dev-ruby/ruby_parser: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/ruby_parser')
-rw-r--r--dev-ruby/ruby_parser/Manifest2
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.13.0.ebuild38
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.9.0.ebuild35
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-ruby/ruby_parser/Manifest b/dev-ruby/ruby_parser/Manifest
index 338ab3a00fc9..618d8d5e3234 100644
--- a/dev-ruby/ruby_parser/Manifest
+++ b/dev-ruby/ruby_parser/Manifest
@@ -1,3 +1 @@
-DIST ruby_parser-3.13.0.gem 442880 BLAKE2B b4ebbce3aa82465d8d377825908acb5601aa2109b0cacfb861e6abbdcdd4ce5e089c1f48a174f4cda67515a935450803c70abfe0e80a3818c04c5d657c896c06 SHA512 879893ec6f82a8c9fd7bcdf670fdfc864dbe30cfe799dc3841bdab3430dd7c126f086496cda1861b2a3cc1b5585746721f81ecf053728926e000c5041c744314
DIST ruby_parser-3.13.1.gem 445952 BLAKE2B 7df7bbfe3f7f700747d32bd5c66d94fdd7c57974e622969958dda39f4dc8656a4211378ba51c4b8e8eefafebf82e550ab73a775530eab06ff6419a3dee7f8f7b SHA512 90c8b68245168c7df4ec8d0e6c62d9723d759945823768645614fe085f375c6811a15c35334c485cb59f32f6adb1aa0a06e7df043b09a48ef4e6102d93562b1b
-DIST ruby_parser-3.9.0.gem 411648 BLAKE2B ba5247a408c24c2ac36561ed9c26b4124a61565327247ee5dc3315a9f3e1f995fd6419c19ee8013efcc2b30fd752b3c8f6dd24011d35168f7e8cbcd224ddb909 SHA512 f609084d82caf4c33a40b64ee9df473375f00c59a34ec5b419f155a54a7fb9436ffb77ace406a01974c6c0d7b11b97447da0b3053c1fd87c66eb0406a0150312
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.13.0.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.13.0.ebuild
deleted file mode 100644
index ecb7abcfefbf..000000000000
--- a/dev-ruby/ruby_parser/ruby_parser-3.13.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby parser written in pure ruby"
-HOMEPAGE="https://github.com/seattlerb/ruby_parser"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/sexp_processor-4.9.0:4
- !<dev-ruby/ruby_parser-2.3.1-r1"
-
-ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 >=dev-ruby/sexp_processor-4.12.0:4 )"
-
-DEPEND+=" test? ( dev-util/unifdef )"
-
-all_ruby_prepare() {
- # Remove reference to perforce method that is not in a released
- # version of hoe-seattlerb.
- #sed -i -e '/perforce/d' Rakefile || die
- sed -i -e '/license/d' Rakefile || die
- sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.9.0.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.9.0.ebuild
deleted file mode 100644
index 5fe4ba7a644c..000000000000
--- a/dev-ruby/ruby_parser/ruby_parser-3.9.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby parser written in pure ruby"
-HOMEPAGE="https://github.com/seattlerb/ruby_parser"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/sexp_processor-4.9.0:4
- !<dev-ruby/ruby_parser-2.3.1-r1"
-
-ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
-ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 )"
-
-DEPEND+=" test? ( dev-util/unifdef )"
-
-all_ruby_prepare() {
- # Remove reference to perforce method that is not in a released
- # version of hoe-seattlerb.
- #sed -i -e '/perforce/d' Rakefile || die
- sed -i -e '/license/d' Rakefile || die
- sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
-}