summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-22 10:13:06 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-23 07:04:46 +0200
commit59012e388f3fcdf33885a479577364a8676be7a6 (patch)
tree49986789337f13e8349e1352ae8d6393d4d33117 /dev-ruby/singleton
parentdev-python/cherrypy: Enable py3.11 (diff)
downloadgentoo-59012e388f3fcdf33885a479577364a8676be7a6.tar.gz
gentoo-59012e388f3fcdf33885a479577364a8676be7a6.tar.bz2
gentoo-59012e388f3fcdf33885a479577364a8676be7a6.zip
dev-ruby/singleton: initial import of 0.1.1
Dependency for forthcoming dev-ruby/prime. Extracted from dev-lang/ruby, keywords set accordingly. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/singleton')
-rw-r--r--dev-ruby/singleton/Manifest1
-rw-r--r--dev-ruby/singleton/metadata.xml11
-rw-r--r--dev-ruby/singleton/singleton-0.1.1.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/singleton/Manifest b/dev-ruby/singleton/Manifest
new file mode 100644
index 000000000000..147c82fcab11
--- /dev/null
+++ b/dev-ruby/singleton/Manifest
@@ -0,0 +1 @@
+DIST singleton-0.1.1.tar.gz 4975 BLAKE2B 3957c7d622aaad6a71b5675ad950b2a4622ec520b59075df25a966609e54c2f47581ba35c5a004c67a1a36f50de13dacadbc96ee1fd113790e6793e97131787c SHA512 a0817b42e8b056488b999eca8de09d75efe79e5624f4817289164d90051c92279dc9f8a087e69df89bec913127c460b8b6586fde17b73e08d4ec5b6da4dec18d
diff --git a/dev-ruby/singleton/metadata.xml b/dev-ruby/singleton/metadata.xml
new file mode 100644
index 000000000000..2c38c2ef94ba
--- /dev/null
+++ b/dev-ruby/singleton/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/singleton</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/singleton/singleton-0.1.1.ebuild b/dev-ruby/singleton/singleton-0.1.1.ebuild
new file mode 100644
index 000000000000..cabbd7428cfa
--- /dev/null
+++ b/dev-ruby/singleton/singleton-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="singleton.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Singleton module implements the Singleton pattern"
+HOMEPAGE="https://github.com/ruby/singleton"
+SRC_URI="https://github.com/ruby/singleton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}