summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/six
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/six')
-rw-r--r--dev-ruby/six/Manifest1
-rw-r--r--dev-ruby/six/metadata.xml8
-rw-r--r--dev-ruby/six/six-0.2.0.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/six/Manifest b/dev-ruby/six/Manifest
new file mode 100644
index 000000000000..d68f50e84e5e
--- /dev/null
+++ b/dev-ruby/six/Manifest
@@ -0,0 +1 @@
+DIST six-0.2.0.tar.gz 6747 SHA256 39e9c62fa1893be103615adbd0bff4a315085fea0297c6f0acd7ebbd29e2f0a7 SHA512 8c3bfbe2b07b5682b696800a9235ebf542c7d292f69728aa9c9707f92fa042fe7bfee6a0b28808dab86f8ec80fec5ba993be5e42f4a098d8cfccbc7611fa2016 WHIRLPOOL a3f64020d0a1c081605f77776c0f876fb6734aa84df5edbfec047c2cc9ca1d6b878d1a687055f4c998061e76e288e03900ed9ac540c444b60e611f0c8aab8063
diff --git a/dev-ruby/six/metadata.xml b/dev-ruby/six/metadata.xml
new file mode 100644
index 000000000000..2979cc714c0f
--- /dev/null
+++ b/dev-ruby/six/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">randx/six</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/six/six-0.2.0.ebuild b/dev-ruby/six/six-0.2.0.ebuild
new file mode 100644
index 000000000000..cac733170679
--- /dev/null
+++ b/dev-ruby/six/six-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An ultra lite authorization library"
+HOMEPAGE="https://github.com/randx/six"
+SRC_URI="https://github.com/randx/six/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die "sed failed"
+}