summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-29 08:05:08 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-29 11:06:52 +0200
commit13254656dd64d35d8f9f2f28ae9c9606edad898b (patch)
treef877542a6e0565fa00d21ca2fd07ba80d8c5998f /dev-ruby/tty-command
parentdev-ruby/minitest: add 5.12.2 (diff)
downloadgentoo-13254656dd64d35d8f9f2f28ae9c9606edad898b.tar.gz
gentoo-13254656dd64d35d8f9f2f28ae9c9606edad898b.tar.bz2
gentoo-13254656dd64d35d8f9f2f28ae9c9606edad898b.zip
dev-ruby/tty-command: add 0.9.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-command')
-rw-r--r--dev-ruby/tty-command/Manifest1
-rw-r--r--dev-ruby/tty-command/tty-command-0.9.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
index b8f21fb31199..32f255fc64cd 100644
--- a/dev-ruby/tty-command/Manifest
+++ b/dev-ruby/tty-command/Manifest
@@ -1 +1,2 @@
DIST tty-command-0.8.2.tar.gz 30126 BLAKE2B 858b9c60380859bd984295e00638ba93416c62acbe4e5c1d0e33b411862d729c129f00dda236f4ca9943962859a35c9fe1fa2431327fb2e3170366412f8d83e3 SHA512 151af5fe0cf241b4e8004560d04fe967d8fe1d24cf311d64c4fab46d1c11b1fe27849f3925f13d3a73b7b86a55aabacd3e4bbffa9a96c34669c93b29756fe88e
+DIST tty-command-0.9.0.tar.gz 30463 BLAKE2B fc0436a80b4b73040a89f085315f50e464efd91d6ee222f7b94eec5b94700089ae22963580febf8296377c859c67f1f21772ecd24d325af76308183df6070e2a SHA512 12c5c238ea34b7236b1c1b3115a7f490ae3986de686359ed390428f766aabdb35de7a1b29363b5be4e09e0fb6888b0c8a30eb466153f64b1d8a77620a657ffac
diff --git a/dev-ruby/tty-command/tty-command-0.9.0.ebuild b/dev-ruby/tty-command/tty-command-0.9.0.ebuild
new file mode 100644
index 000000000000..d5da980e9186
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/pastel-0.7*"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}