summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-16 09:03:47 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-16 09:03:47 +0200
commit1e3f83d85b5ae5bf7be89040e91e30f477b75d36 (patch)
treefa906ca483df4a8644e9de9a7083afb34e949899 /dev-ruby/will_paginate
parentdev-ruby/whole_history_rating: enable ruby30, ruby31 and disable ruby24, ruby25 (diff)
downloadgentoo-1e3f83d85b5ae5bf7be89040e91e30f477b75d36.tar.gz
gentoo-1e3f83d85b5ae5bf7be89040e91e30f477b75d36.tar.bz2
gentoo-1e3f83d85b5ae5bf7be89040e91e30f477b75d36.zip
dev-ruby/will_paginate: limit rails version for tests
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/will_paginate')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.3.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
index ce6a5ea33efd..0c766344ec96 100644
--- a/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
+++ b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,11 +21,14 @@ IUSE=""
all_ruby_prepare() {
# Remove tests for unpackaged ORMs
rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+
+ # Use a supported rails version
+ sed -e '1igem "activerecord", "<7"; gem "actionpack", "<7"' -i spec/spec_helper.rb || die
}
ruby_add_bdepend "
test? (
- dev-ruby/rails
+ <dev-ruby/rails-7
dev-ruby/sqlite3
dev-ruby/mocha
)"