summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-04-17 07:21:06 +0200
committerHans de Graaff <graaff@gentoo.org>2024-04-17 07:21:06 +0200
commit102126d12af91c13bea173cea46e0cbdbb492fd1 (patch)
treebd6239a4d2b735d154f9561b5035ad93b46651d7 /dev-ruby
parentwww-plugins/chrome-binary-plugins: Fix QA errors (diff)
downloadgentoo-102126d12af91c13bea173cea46e0cbdbb492fd1.tar.gz
gentoo-102126d12af91c13bea173cea46e0cbdbb492fd1.tar.bz2
gentoo-102126d12af91c13bea173cea46e0cbdbb492fd1.zip
dev-ruby/dnsruby: add 1.72.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/dnsruby/Manifest1
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.72.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/dnsruby/Manifest b/dev-ruby/dnsruby/Manifest
index 403cfe0e91f4..70305adc952b 100644
--- a/dev-ruby/dnsruby/Manifest
+++ b/dev-ruby/dnsruby/Manifest
@@ -1,3 +1,4 @@
DIST dnsruby-1.70.0.gem 261632 BLAKE2B 07adbe23ab2d1605c1562f4403f2dd864171b047df08037763565a3a459f2d3b3cb79343da2c25aadb498a7fc5a81a42af928d65a22c6b736fa7b64fab96721f SHA512 11caddd4ea5c9b8f85c730708d3cd1e1a130059975dfdecbf307862f7cbb85285d193f9ce010a81fbd8a7518ec720a107118018146d67105f6a4dbd41149a130
DIST dnsruby-1.71.0.gem 262144 BLAKE2B 6067bad3953eab96856adc6a30f43241c0fc6166ab3476257a502ef593ec186420d6b89c5f8e0c162bdcde5249365c02c6910e0706fbacd0425af5734b7752a8 SHA512 9488de8e6ed72708dd8ec213eb5814d8bf712a5186103cc8bcea26d9d9df1933e3d515bd2915622e643b7a37d9a94ac295f6638ac73fcf30f1dfd26c79d32c63
DIST dnsruby-1.72.0.gem 262144 BLAKE2B 6b802c6276c32c5df6db5babb73c95f9a7c732159539197001607df89bdb144473d67252721f5f3b292cf2e5fa304611d1ce313e0cd8d09e161d4fa1867ff409 SHA512 2f2a26cc2503fb4d3521d76e4a5d476d1447439035e2bfbec0ebab34352a56f0a9c5445db15baefd7be5ba024f03d574b8b1e49a83ad4799d2c9de20e2966c83
+DIST dnsruby-1.72.1.gem 262144 BLAKE2B 5ef7b91663cb14563e75adf643eae479c787552487c826dade7cb78885ca5f6eaed8ebd7f7529853b57e3fb833c781e15c10f8f8e90241529e2c833aef160df0 SHA512 9113db85001983036ba81d230d04ce2b95fdd9ae6923d7887fe3398dfdbb91d7c005b8b92701b386ef53789b1351ff1e32bc3f00b3254ec9371f4575ea7fed3f
diff --git a/dev-ruby/dnsruby/dnsruby-1.72.1.ebuild b/dev-ruby/dnsruby/dnsruby-1.72.1.ebuild
new file mode 100644
index 000000000000..13e241e00b9c
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.72.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="https://github.com/alexdalitz/dnsruby"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/simpleidn-0.2.1:0 =dev-ruby/simpleidn-0.2*:0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]overall/d" Rakefile || die
+ sed -i -e '/display/d' \
+ -e '/Display/,/^}/d' test/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ # only run offline tests
+ # ${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}