summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-25 07:26:44 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-25 07:37:28 +0100
commit216ff8dcb546bb9d10aa820ce7f99fed9815aece (patch)
tree7a0c8425be9b499b6d121850b3c8dabaf5c3b58d /dev-ruby
parentdev-ada/gnatmem: rm gnat_2019 and old ebuilds (diff)
downloadgentoo-216ff8dcb546bb9d10aa820ce7f99fed9815aece.tar.gz
gentoo-216ff8dcb546bb9d10aa820ce7f99fed9815aece.tar.bz2
gentoo-216ff8dcb546bb9d10aa820ce7f99fed9815aece.zip
dev-ruby/narray: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/narray/narray-0.6.1.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/narray/narray-0.6.1.2.ebuild b/dev-ruby/narray/narray-0.6.1.2.ebuild
deleted file mode 100644
index 34ca5260bb13..000000000000
--- a/dev-ruby/narray/narray-0.6.1.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md README.ja.md SPEC.en.txt SPEC.ja.txt"
-
-RUBY_FAKEGEM_VERSION="${PV/_p/.}"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Numerical N-dimensional Array class"
-HOMEPAGE="https://masa16.github.io/narray/"
-SRC_URI="https://github.com/masa16/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ~mips ppc ~ppc64 x86"
-
-IUSE=""
-
-all_ruby_prepare() {
- # the tests aren't really written to be a testsuite, so the
- # failure cases will literally fail; ignore all of those and
- # instead expect that the rest won't fail.
- sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
- -e '/next will fail/,$ s:^:#:' \
- test/*.rb || die "sed failed"
-}
-
-each_ruby_configure() {
- ${RUBY} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp -l ${PN}$(get_modname) ${PN}.h ${PN}_config.h lib/ || die "copy of ${PN}$(get_modname) failed"
-}
-
-each_ruby_test() {
- for unit in test/*; do
- ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
- done
-}