summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-07 20:17:45 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-07 20:34:05 +0200
commit7c5b1cb70f2fcf91df41858d84a74d59b46ec3bf (patch)
tree88ac9b9b43ca64415847e27d3f38cc90679db8e9 /dev-ruby
parentdev-ruby/sass-rails: Prune slot 3.2 (diff)
downloadgentoo-7c5b1cb70f2fcf91df41858d84a74d59b46ec3bf.tar.gz
gentoo-7c5b1cb70f2fcf91df41858d84a74d59b46ec3bf.tar.bz2
gentoo-7c5b1cb70f2fcf91df41858d84a74d59b46ec3bf.zip
dev-ruby/mongoid: Remove last-rited pkg
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mongoid/Manifest1
-rw-r--r--dev-ruby/mongoid/metadata.xml11
-rw-r--r--dev-ruby/mongoid/mongoid-2.8.1.ebuild81
3 files changed, 0 insertions, 93 deletions
diff --git a/dev-ruby/mongoid/Manifest b/dev-ruby/mongoid/Manifest
deleted file mode 100644
index 85dc7c5674bb..000000000000
--- a/dev-ruby/mongoid/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mongoid-2.8.1.tar.gz 367336 SHA256 76289084e680fe4ba476112eadda9dac0212a28e169023e84788db8a56494305 SHA512 cdd7e92722a5451c8d9ef0a21b7176446f9d6f41f42f62e0f91006feb6217a4a5c3bf2b193ee57d196aef2a61dc13b50cd76c35da295140abc4a7136d02eda81 WHIRLPOOL b4bc238ef853b1bc8dd42169f1075bd75f6f10fbe02c41aedf93901cb66d79527d6815c8934da2738f8f82ff24081995f6487fc4959888b25014f25509110dd6
diff --git a/dev-ruby/mongoid/metadata.xml b/dev-ruby/mongoid/metadata.xml
deleted file mode 100644
index aab09e315281..000000000000
--- a/dev-ruby/mongoid/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">mongoid/mongoid</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/mongoid/mongoid-2.8.1.ebuild b/dev-ruby/mongoid/mongoid-2.8.1.ebuild
deleted file mode 100644
index 32e97221ed82..000000000000
--- a/dev-ruby/mongoid/mongoid-2.8.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-# functional testing crashes Ruby from within Portage, but works
-# outside of it, needs to be investigated thoroughly, but at least
-# unit testing works.
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="${PN}"
-GITHUB_PROJECT="${PN}"
-
-inherit ruby-fakegem
-
-DESCRIPTION="ODM (Object Document Mapper) Framework for MongoDB"
-HOMEPAGE="http://two.mongoid.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/activemodel-3.1 =dev-ruby/activemodel-3*
- >=dev-ruby/mongo-1.9:0
- >=dev-ruby/tzinfo-0.3.22:0
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- dev-ruby/ammeter
- dev-ruby/mocha:0.11
- dev-ruby/rdoc
- dev-ruby/rspec
- dev-util/watchr
- )"
-
-DEPEND+=" test? ( dev-db/mongodb )"
-
-all_ruby_prepare() {
- # Remove unsupported development dependencies and fix versions.
- sed -i -e '/\(guard-rspec\|rb-fsevent\)/ s:^:#:' \
- -e '/mocha/ s/= 0.11/~> 0.11.0/' mongoid.gemspec || die
-
- # Avoid specs tied to localhost
- rm spec/functional/mongoid/config/{database,replset_database}_spec.rb || die
-
- # Avoid some failing specs that should be investigated later
- sed -i -e '/sets the capped size/,/end/ s:^:#:' spec/functional/mongoid/collection_spec.rb || die
- sed -i -e '/.from_hash/,/^ end/ s:^:#:' spec/functional/mongoid/config_spec.rb || die
- rm spec/functional/mongoid/persistence_spec.rb || die
-}
-
-each_ruby_test() {
- mkdir "${T}/mongodb_$(basename $RUBY)"
- mongod --port 27017 --dbpath "${T}/mongodb_$(basename $RUBY)" \
- --noprealloc --noauth --nohttpinterface --nounixsocket --nojournal \
- --bind_ip 127.255.255.254 &
- mongod_pid=$!
- failed=0
-
- sleep 2
-
- export MONGOID_SPEC_HOST="127.255.255.254"
- export MONGOID_SPEC_PORT="27017"
-
- ${RUBY} -S bundle exec rspec-2 --format progress spec || failed=1
- kill "${mongod_pid}"
-
- [[ "${failed}" == "1" ]] && die "tests failed"
-}