summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-27 07:39:09 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-27 13:24:48 +0200
commitf3ddf8c9da5a55971c2eaf6cfa6941847d644fb2 (patch)
treec508dada51d809c47b9df05a9937033214b3ac5f /dev-ruby
parentdev-ruby/fcgi: EAPI 8; add ruby30; fix extension install (diff)
downloadgentoo-f3ddf8c9da5a55971c2eaf6cfa6941847d644fb2.tar.gz
gentoo-f3ddf8c9da5a55971c2eaf6cfa6941847d644fb2.tar.bz2
gentoo-f3ddf8c9da5a55971c2eaf6cfa6941847d644fb2.zip
dev-ruby/curb: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/curb/Manifest1
-rw-r--r--dev-ruby/curb/curb-0.9.10.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-ruby/curb/Manifest b/dev-ruby/curb/Manifest
index e30b5ce8ea56..1379991cb891 100644
--- a/dev-ruby/curb/Manifest
+++ b/dev-ruby/curb/Manifest
@@ -1,2 +1 @@
-DIST curb-0.9.10.gem 88064 BLAKE2B 8f761e752bc1fd0775f012373847330d3ced9d394e5159b74c8e329247f6221bbc26978755d84b91e75b4082b7bb50c7755db299f90f291516f355b4ab1ddc7c SHA512 eab82d3c1b34bf8e5bfd334abca38a80eaab255d31164ca189185b8b98d7f3760fb116babf50dce5aef01be30b15e9374e7a84e1b0926dba13c3e9f8d36c54ca
DIST curb-0.9.11.gem 88576 BLAKE2B 1656a17070151ddd1bd63c3e23885d36d8e2b133b19e00347892363a9a20c88baa10932ceb5273733b18847d8d19dc403aa4b7f36fbd80c8dde126ae46743796 SHA512 000ee2054a5866de09042dfc5894330900e401aa94a0fe8bb133fe9c661f7899992adff0585e5ed3725d3564cd9819d76653655f3539faaa61ca6acabe3a8602
diff --git a/dev-ruby/curb/curb-0.9.10.ebuild b/dev-ruby/curb/curb-0.9.10.ebuild
deleted file mode 100644
index 254c1ed7ff49..000000000000
--- a/dev-ruby/curb/curb-0.9.10.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # Fix test that expects wrong output
- sed -i -e 's/200 OK /200 OK/' tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
- cp -l ext/curb_core$(get_modname) lib || die
-}