summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-11-27 15:32:16 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-11-27 15:39:04 +0900
commit9d703f43293f148219ceca108ab602083b417c03 (patch)
tree6633b26ed6b84d01686079c495d3db4932bb0dfc /dev-scheme/stklos/stklos-1.10-r2.ebuild
parentdev-scheme/stklos: update LICENSE (diff)
downloadgentoo-9d703f43293f148219ceca108ab602083b417c03.tar.gz
gentoo-9d703f43293f148219ceca108ab602083b417c03.tar.bz2
gentoo-9d703f43293f148219ceca108ab602083b417c03.zip
dev-scheme/stklos: update to EAPI 8
Closes: https://bugs.gentoo.org/423823 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-scheme/stklos/stklos-1.10-r2.ebuild')
-rw-r--r--dev-scheme/stklos/stklos-1.10-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-scheme/stklos/stklos-1.10-r2.ebuild b/dev-scheme/stklos/stklos-1.10-r2.ebuild
new file mode 100644
index 000000000000..6fd3a1acef34
--- /dev/null
+++ b/dev-scheme/stklos/stklos-1.10-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="fast and light Scheme implementation"
+HOMEPAGE="https://www.stklos.net/"
+SRC_URI="https://www.${PN}.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+RDEPEND="dev-libs/boehm-gc[threads?]
+ dev-libs/gmp:=
+ dev-libs/libffi:=
+ dev-libs/libpcre"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS PACKAGES-USED PORTING-NOTES README SUPPORTED-SRFIS )
+
+src_prepare() {
+ rm -rf {ffi,gc,gmp,pcre}
+
+ default
+}
+
+src_configure() {
+ econf \
+ --enable-threads=$(usex threads pthreads none) \
+ --without-gmp-light \
+ --without-provided-ffi \
+ --without-provided-gc \
+ --without-provided-regexp
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ einstalldocs
+}