summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-16 21:37:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-16 21:38:13 +0100
commit39c12a97877f631adcc1301bc3ea6b8e09d3d9f4 (patch)
treec87608b26f6bcb76f032640704e7a0307a7637a2 /dev-tcltk
parentapp-crypt/debian-archive-keyring: 2023.1 + EAPI 8 (diff)
downloadgentoo-39c12a97877f631adcc1301bc3ea6b8e09d3d9f4.tar.gz
gentoo-39c12a97877f631adcc1301bc3ea6b8e09d3d9f4.tar.bz2
gentoo-39c12a97877f631adcc1301bc3ea6b8e09d3d9f4.zip
dev-tcltk/thread: remove non-standard test for thread join
Closes: https://bugs.gentoo.org/835487 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/files/thread-2.8.5-musl.patch18
-rw-r--r--dev-tcltk/thread/thread-2.8.5.ebuild4
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-tcltk/thread/files/thread-2.8.5-musl.patch b/dev-tcltk/thread/files/thread-2.8.5-musl.patch
new file mode 100644
index 000000000000..b31f8948d6e1
--- /dev/null
+++ b/dev-tcltk/thread/files/thread-2.8.5-musl.patch
@@ -0,0 +1,18 @@
+--- a/tests/thread.test 2023-03-16 21:31:05.333423098 +0100
++++ b/tests/thread.test 2023-03-16 21:31:25.837324400 +0100
+@@ -100,15 +100,6 @@
+ set c
+ } {0}
+
+-test thread-4.5 {thread::create - join detached thread} {
+- ThreadReap
+- set tid [thread::create]
+- thread::send -async $tid {after 1000 ; thread::release}
+- catch {set res [thread::join $tid]} msg
+- ThreadReap
+- lrange $msg 0 2
+-} {cannot join thread}
+-
+ test thread-5.0 {thread::release} {
+ ThreadReap
+ set tid [thread::create {thread::release}]
diff --git a/dev-tcltk/thread/thread-2.8.5.ebuild b/dev-tcltk/thread/thread-2.8.5.ebuild
index 240a6f7ee101..cb6b5e7e0a40 100644
--- a/dev-tcltk/thread/thread-2.8.5.ebuild
+++ b/dev-tcltk/thread/thread-2.8.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,6 +21,8 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
src_prepare() {
default