summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/biber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/biber')
-rw-r--r--dev-tex/biber/Manifest2
-rw-r--r--dev-tex/biber/biber-1.9.ebuild70
-rw-r--r--dev-tex/biber/biber-2.1.ebuild74
-rw-r--r--dev-tex/biber/files/biber-1.9-drop-mozilla-ca.patch221
-rw-r--r--dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch197
-rw-r--r--dev-tex/biber/metadata.xml12
6 files changed, 576 insertions, 0 deletions
diff --git a/dev-tex/biber/Manifest b/dev-tex/biber/Manifest
new file mode 100644
index 000000000000..dbc6684317ff
--- /dev/null
+++ b/dev-tex/biber/Manifest
@@ -0,0 +1,2 @@
+DIST biber-1.9.tar.gz 2046569 SHA256 4b8f7ab78f326f2c862c99f8dbb3b224c49f9289820dc226c9529dfa945d9066 SHA512 6b417fd2537e832e8309e3cd1405037a0e1a6e1bc2f2759a208a97f1107a787c269eb3dd9a5b3875855dd50d641dbe7d61b7127d11f986a05d1ceb08ec6ecfda WHIRLPOOL 47b39ab2e0c35e48f4d627bf24f4c03bbeb6b8f499c6492d403da31098b1eb13cd998713f7fbe38c260dff1418b1bd03aede7fa86cd04baf4d5dbe04816e4377
+DIST biber-2.1.tar.gz 2222706 SHA256 7b20049557869a994ed9e0373f620720370981b6412ca415f0408d1af893f8f4 SHA512 4a19bf9781cb90da52d9f08163b9ed400233db5c446054b12ab339786456e85bc7aba16ff8c0a36351ecc66b90e4a93e594e820b52f93566449b8c96b27852fb WHIRLPOOL 0c7b1827e3e9ede6aebd45a00b63eac8cc3e7896d89c219fa2c467b4b6b10f48f2180aeb70d727f14620267943d59646daf4d0f09ddb1bd7b6b4b945d973dc03
diff --git a/dev-tex/biber/biber-1.9.ebuild b/dev-tex/biber/biber-1.9.ebuild
new file mode 100644
index 000000000000..376fe96a48bc
--- /dev/null
+++ b/dev-tex/biber/biber-1.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_PN=biblatex-${PN}
+
+DESCRIPTION="A BibTeX replacement for users of biblatex"
+HOMEPAGE="http://biblatex-biber.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${MY_PN}/${MY_PN}/${PV}/${MY_PN}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/perl-5.16
+ dev-perl/autovivification
+ dev-perl/Business-ISBN
+ dev-perl/Business-ISMN
+ dev-perl/Business-ISSN
+ dev-perl/Data-Compare
+ dev-perl/Data-Dump
+ dev-perl/Date-Simple
+ dev-perl/Encode-EUCJPASCII
+ dev-perl/Encode-HanExtra
+ dev-perl/Encode-JIS2K
+ dev-perl/File-Slurp-Unicode
+ dev-perl/IPC-Run3
+ dev-perl/libwww-perl[ssl]
+ dev-perl/List-AllUtils
+ dev-perl/Log-Log4perl
+ dev-perl/regexp-common
+ dev-perl/Readonly
+ dev-perl/Readonly-XS
+ >=dev-perl/Text-BibTeX-0.66
+ dev-perl/URI
+ dev-perl/Unicode-LineBreak
+ dev-perl/XML-LibXML-Simple
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-SAX-Base
+ dev-perl/XML-Writer
+ >=dev-tex/biblatex-2.7
+ virtual/perl-IPC-Cmd"
+DEPEND="${RDEPEND}
+ dev-perl/Config-AutoConf
+ dev-perl/Module-Build
+ test? ( dev-perl/File-Which
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+SRC_TEST="parallel"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-drop-mozilla-ca.patch
+}
+
+src_install(){
+ perl-module_src_install
+ use doc && dodoc -r doc/*
+}
+
+src_test() {
+ BIBER_SKIP_DEV_TESTS=1 perl-module_src_test
+}
diff --git a/dev-tex/biber/biber-2.1.ebuild b/dev-tex/biber/biber-2.1.ebuild
new file mode 100644
index 000000000000..e4268bbc6880
--- /dev/null
+++ b/dev-tex/biber/biber-2.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_PN=biblatex-${PN}
+
+DESCRIPTION="A BibTeX replacement for users of biblatex"
+HOMEPAGE="http://biblatex-biber.sourceforge.net/ https://github.com/plk/biber/"
+SRC_URI="https://github.com/plk/biber/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/perl-5.16
+ dev-perl/autovivification
+ dev-perl/Business-ISBN
+ dev-perl/Business-ISMN
+ dev-perl/Business-ISSN
+ dev-perl/Data-Compare
+ dev-perl/Data-Dump
+ dev-perl/Date-Simple
+ dev-perl/Encode-EUCJPASCII
+ dev-perl/Encode-HanExtra
+ dev-perl/Encode-JIS2K
+ dev-perl/File-Slurp-Unicode
+ dev-perl/IPC-Run3
+ dev-perl/libwww-perl[ssl]
+ dev-perl/List-AllUtils
+ >=dev-perl/List-MoreUtils-0.408.0
+ dev-perl/Log-Log4perl
+ dev-perl/LWP-Protocol-https
+ dev-perl/regexp-common
+ dev-perl/Readonly
+ dev-perl/Readonly-XS
+ dev-perl/Text-Roman
+ >=dev-perl/Text-BibTeX-0.700.0
+ dev-perl/URI
+ dev-perl/Unicode-LineBreak
+ dev-perl/Unicode-Normalize
+ dev-perl/XML-LibXML-Simple
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-SAX-Base
+ dev-perl/XML-Writer
+ >=dev-tex/biblatex-3.0
+ virtual/perl-IPC-Cmd
+ >=virtual/perl-Unicode-Collate-1.120.0"
+DEPEND="${RDEPEND}
+ dev-perl/Config-AutoConf
+ dev-perl/Module-Build
+ test? ( dev-perl/File-Which
+ dev-perl/Test-Differences
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="parallel"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-drop-mozilla-ca.patch
+}
+
+src_install(){
+ perl-module_src_install
+ use doc && dodoc -r doc/*
+}
+
+src_test() {
+ BIBER_SKIP_DEV_TESTS=1 perl-module_src_test
+}
diff --git a/dev-tex/biber/files/biber-1.9-drop-mozilla-ca.patch b/dev-tex/biber/files/biber-1.9-drop-mozilla-ca.patch
new file mode 100644
index 000000000000..54732a603989
--- /dev/null
+++ b/dev-tex/biber/files/biber-1.9-drop-mozilla-ca.patch
@@ -0,0 +1,221 @@
+From f31062a94aefff64cc193aa3a394fd3a623c2aa7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Manuel=20R=C3=BCger?= <manuel@rueg.eu>
+Date: Thu, 29 May 2014 14:23:06 +0200
+Subject: [PATCH] Remove Mozilla::CA dependency.
+
+
+diff --git a/Build.PL b/Build.PL
+index 3ea589b..76acdc7 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -49,7 +49,6 @@ my $builder = $class->new(
+ 'IPC::Run3' => 0,
+ 'List::AllUtils' => 0,
+ 'List::MoreUtils' => 0,
+- 'Mozilla::CA' => '20130114',
+ 'Regexp::Common' => 0,
+ 'Log::Log4perl' => 0,
+ 'Unicode::Collate' => '1.04',
+diff --git a/META.json b/META.json
+index cf91a91..1855294 100644
+--- a/META.json
++++ b/META.json
+@@ -44,7 +44,6 @@
+ "List::AllUtils" : "0",
+ "List::MoreUtils" : "0",
+ "Log::Log4perl" : "0",
+- "Mozilla::CA" : "20130114",
+ "Regexp::Common" : "0",
+ "Text::BibTeX" : "0.69",
+ "URI" : "0",
+diff --git a/META.yml b/META.yml
+index 7091ddb..82706ee 100644
+--- a/META.yml
++++ b/META.yml
+@@ -114,7 +114,6 @@ requires:
+ List::AllUtils: 0
+ List::MoreUtils: 0
+ Log::Log4perl: 0
+- Mozilla::CA: 20130114
+ Regexp::Common: 0
+ Text::BibTeX: 0.69
+ URI: 0
+diff --git a/bin/biber b/bin/biber
+index 6038535..4c3ea1c 100755
+--- a/bin/biber
++++ b/bin/biber
+@@ -73,7 +73,6 @@ GetOptions(
+ 'sortfirstinits=s',
+ 'sortlocale|l=s',
+ 'sortupper=s',
+- 'ssl-nointernalca',
+ 'ssl-noverify-host',
+ 'tool',
+ 'tool_align|tool-align', # legacy alias for output_align
+@@ -664,12 +663,6 @@ default sorting (B<--collate|-C>). When
+ using B<--fastsort|-f>, your OS collation locale determines
+ this and this option is ignored (default is true).
+
+-=item B<--ssl-nointernalca>
+-
+-Don't try to use the default Mozilla CA certificates when using HTTPS to fetch remote data.
+-This assumes that the user will set one of the perl LWP::UserAgent module environment variables
+-to find the CA certs.
+-
+ =item B<--ssl-noverify-host>
+
+ Turn off host verification when using HTTPS to fetch remote data sources.
+diff --git a/data/schemata/config.rnc b/data/schemata/config.rnc
+index e798733..5fcce6d 100644
+--- a/data/schemata/config.rnc
++++ b/data/schemata/config.rnc
+@@ -72,7 +72,6 @@ start = element config {
+ map+
+ }+
+ }? &
+- element ssl-nointernalca { "0" | "1" }? &
+ element ssl-noverify-host { "0" | "1" }? &
+ element tool { "0" | "1" }? &
+ element tool_config { text }? &
+diff --git a/data/schemata/config.rng b/data/schemata/config.rng
+index 185cde6..f7e4176 100644
+--- a/data/schemata/config.rng
++++ b/data/schemata/config.rng
+@@ -335,14 +335,6 @@
+ </element>
+ </optional>
+ <optional>
+- <element name="ssl-nointernalca">
+- <choice>
+- <value>0</value>
+- <value>1</value>
+- </choice>
+- </element>
+- </optional>
+- <optional>
+ <element name="ssl-noverify-host">
+ <choice>
+ <value>0</value>
+diff --git a/lib/Biber/Input/file/biblatexml.pm b/lib/Biber/Input/file/biblatexml.pm
+index d3f7377..21b1471 100644
+--- a/lib/Biber/Input/file/biblatexml.pm
++++ b/lib/Biber/Input/file/biblatexml.pm
+@@ -97,19 +97,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/bibtex.pm b/lib/Biber/Input/file/bibtex.pm
+index 33185a6..f3fd9f2 100644
+--- a/lib/Biber/Input/file/bibtex.pm
++++ b/lib/Biber/Input/file/bibtex.pm
+@@ -140,19 +140,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/endnotexml.pm b/lib/Biber/Input/file/endnotexml.pm
+index 14adc38..b880e8a 100644
+--- a/lib/Biber/Input/file/endnotexml.pm
++++ b/lib/Biber/Input/file/endnotexml.pm
+@@ -111,19 +111,6 @@ sub extract_entries {
+ $logger->info("Data source '$source' is a remote EndNote XML datasource - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/ris.pm b/lib/Biber/Input/file/ris.pm
+index 0dbeacc..dda7466 100644
+--- a/lib/Biber/Input/file/ris.pm
++++ b/lib/Biber/Input/file/ris.pm
+@@ -110,19 +110,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/zoterordfxml.pm b/lib/Biber/Input/file/zoterordfxml.pm
+index 0d05d2b..79ba19e 100644
+--- a/lib/Biber/Input/file/zoterordfxml.pm
++++ b/lib/Biber/Input/file/zoterordfxml.pm
+@@ -123,19 +123,6 @@ sub extract_entries {
+ $logger->info("Data source '$source' is a remote Zotero RDF/XML data source - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+--
+2.0.0
+
diff --git a/dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch b/dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch
new file mode 100644
index 000000000000..beaf08356665
--- /dev/null
+++ b/dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch
@@ -0,0 +1,197 @@
+From 29a48e5da01acb1f5f35e3a47b04ec4db42e50b9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Manuel=20R=C3=BCger?= <manuel@rueg.eu>
+Date: Sun, 31 May 2015 00:34:11 +0200
+Subject: [PATCH] Remove Mozilla::CA dependency.
+
+
+diff --git a/Build.PL b/Build.PL
+index 841af36..b43b5fe 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -53,7 +53,6 @@ my $builder = $class->new(
+ 'List::AllUtils' => 0,
+ 'List::MoreUtils' => 0,
+ 'List::MoreUtils::XS' => 0,
+- 'Mozilla::CA' => '20141217',
+ 'Regexp::Common' => 0,
+ 'Log::Log4perl' => 0,
+ 'Unicode::Collate' => '1.12',
+diff --git a/bin/biber b/bin/biber
+index 80ebd39..c4f8897 100755
+--- a/bin/biber
++++ b/bin/biber
+@@ -72,7 +72,6 @@ GetOptions(
+ 'sortfirstinits=s',
+ 'sortlocale|l=s',
+ 'sortupper=s',
+- 'ssl-nointernalca',
+ 'ssl-noverify-host',
+ 'tool',
+ 'tool_align|tool-align', # legacy alias for output_align
+@@ -658,12 +657,6 @@ default sorting (B<--collate|-C>). When
+ using B<--fastsort|-f>, your OS collation locale determines
+ this and this option is ignored (default is true).
+
+-=item B<--ssl-nointernalca>
+-
+-Don't try to use the default Mozilla CA certificates when using HTTPS to fetch remote data.
+-This assumes that the user will set one of the perl LWP::UserAgent module environment variables
+-to find the CA certs.
+-
+ =item B<--ssl-noverify-host>
+
+ Turn off host verification when using HTTPS to fetch remote data sources.
+diff --git a/data/schemata/config.rnc b/data/schemata/config.rnc
+index 9f96fec..2863e14 100644
+--- a/data/schemata/config.rnc
++++ b/data/schemata/config.rnc
+@@ -77,7 +77,6 @@ start = element config {
+ map+
+ }+
+ }? &
+- element ssl-nointernalca { "0" | "1" }? &
+ element ssl-noverify-host { "0" | "1" }? &
+ element tool { "0" | "1" }? &
+ element tool_config { text }? &
+diff --git a/data/schemata/config.rng b/data/schemata/config.rng
+index 3bd7072..8ef9bee 100644
+--- a/data/schemata/config.rng
++++ b/data/schemata/config.rng
+@@ -352,14 +352,6 @@
+ </element>
+ </optional>
+ <optional>
+- <element name="ssl-nointernalca">
+- <choice>
+- <value>0</value>
+- <value>1</value>
+- </choice>
+- </element>
+- </optional>
+- <optional>
+ <element name="ssl-noverify-host">
+ <choice>
+ <value>0</value>
+diff --git a/lib/Biber/Input/file/biblatexml.pm b/lib/Biber/Input/file/biblatexml.pm
+index 4d1878b..8994c0f 100644
+--- a/lib/Biber/Input/file/biblatexml.pm
++++ b/lib/Biber/Input/file/biblatexml.pm
+@@ -97,19 +97,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/bibtex.pm b/lib/Biber/Input/file/bibtex.pm
+index 24b2772..c70e6e4 100644
+--- a/lib/Biber/Input/file/bibtex.pm
++++ b/lib/Biber/Input/file/bibtex.pm
+@@ -140,19 +140,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/endnotexml.pm b/lib/Biber/Input/file/endnotexml.pm
+index bf62a80..342b3b2 100644
+--- a/lib/Biber/Input/file/endnotexml.pm
++++ b/lib/Biber/Input/file/endnotexml.pm
+@@ -111,19 +111,6 @@ sub extract_entries {
+ $logger->info("Data source '$source' is a remote EndNote XML datasource - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/ris.pm b/lib/Biber/Input/file/ris.pm
+index bc389c2..56f8d93 100644
+--- a/lib/Biber/Input/file/ris.pm
++++ b/lib/Biber/Input/file/ris.pm
+@@ -110,19 +110,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/zoterordfxml.pm b/lib/Biber/Input/file/zoterordfxml.pm
+index 6dbb3f9..15bc3f6 100644
+--- a/lib/Biber/Input/file/zoterordfxml.pm
++++ b/lib/Biber/Input/file/zoterordfxml.pm
+@@ -123,19 +123,6 @@ sub extract_entries {
+ $logger->info("Data source '$source' is a remote Zotero RDF/XML data source - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+--
+2.4.2
+
diff --git a/dev-tex/biber/metadata.xml b/dev-tex/biber/metadata.xml
new file mode 100644
index 000000000000..b34954eb916b
--- /dev/null
+++ b/dev-tex/biber/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">biblatex-biber</remote-id>
+ <remote-id type="github">plk/biber</remote-id>
+ </upstream>
+</pkgmetadata>