summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2022-03-24 21:00:38 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-03-27 11:12:52 +0800
commit14d25dadca383910e28865144a2316fe302dbf96 (patch)
treeed4cc03d5e1765a0d93e058ecbbf58572ed5105a /dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
parentsci-libs/rocFFT: bump version to 5.0.2 (diff)
downloadgentoo-14d25dadca383910e28865144a2316fe302dbf96.tar.gz
gentoo-14d25dadca383910e28865144a2316fe302dbf96.tar.bz2
gentoo-14d25dadca383910e28865144a2316fe302dbf96.zip
dev-util/Tensile: fix hardcoded EPREFIX in gentoopath.patch
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch')
-rw-r--r--dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch b/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
index 6fda0ddc6a8d..da135e3b38ee 100644
--- a/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
+++ b/dev-util/Tensile/files/Tensile-4.3.0-gentoopath.patch
@@ -17,7 +17,7 @@ Index: Tensile-rocm-4.3.0/Tensile/Source/lib/CMakeLists.txt
if(TENSILE_USE_LLVM)
- find_package(LLVM 13.0 QUIET CONFIG)
-+ find_package(LLVM PATHS /opt/gentoo/usr/lib/llvm/roc QUIET CONFIG)
++ find_package(LLVM PATHS @GENTOO_PORTAGE_EPREFIX@/usr/lib/llvm/roc QUIET CONFIG)
if(NOT LLVM_FOUND)
find_package(LLVM 12.0 QUIET CONFIG)
if(NOT LLVM_FOUND)
@@ -30,7 +30,7 @@ Index: Tensile-rocm-4.3.0/Tensile/Common.py
print2(" %24s: %8s (unspecified)" % (key, defaultValue))
- globalParameters["ROCmPath"] = "/opt/rocm"
-+ globalParameters["ROCmPath"] = "/opt/gentoo/usr"
++ globalParameters["ROCmPath"] = "@GENTOO_PORTAGE_EPREFIX@/usr"
if "ROCM_PATH" in os.environ:
globalParameters["ROCmPath"] = os.environ.get("ROCM_PATH")
if "TENSILE_ROCM_PATH" in os.environ: