summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-01-29 15:48:14 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-01-29 16:45:19 -0500
commit5494b252bc72a82cfc178c3ae64086be67b0192b (patch)
tree6adb4a248d9efb6da4b4e2b86ee52c802b3bc1b9 /dev-util/buildbot-console-view/buildbot-console-view-2.10.1.ebuild
parentdev-util/buildbot-waterfall-view: Version bump to 2.10.1 (diff)
downloadgentoo-5494b252bc72a82cfc178c3ae64086be67b0192b.tar.gz
gentoo-5494b252bc72a82cfc178c3ae64086be67b0192b.tar.bz2
gentoo-5494b252bc72a82cfc178c3ae64086be67b0192b.zip
dev-util/buildbot-console-view: Version bump to 2.10.1
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-console-view/buildbot-console-view-2.10.1.ebuild')
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-2.10.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-2.10.1.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-2.10.1.ebuild
new file mode 100644
index 000000000000..1fe0ebf129ac
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-2.10.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}