summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-08-25 15:56:08 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-08-25 16:24:09 -0700
commit899cf4e0a621586030fb7cb440b5830c09fe9607 (patch)
tree1f7bac98f5c248bc2709fafbb3c952393b5d69bd /dev-util/buildbot-console-view
parentdev-util/buildbot: Version bump to 3.6.0 (diff)
downloadgentoo-899cf4e0a621586030fb7cb440b5830c09fe9607.tar.gz
gentoo-899cf4e0a621586030fb7cb440b5830c09fe9607.tar.bz2
gentoo-899cf4e0a621586030fb7cb440b5830c09fe9607.zip
dev-util/buildbot-console-view: Version bump to 3.6.0
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-3.6.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index 587f8729c8c2..5d1301cd4595 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-console-view-3.4.0.tar.gz 18732 BLAKE2B caeb78d4d3cc616edafccc5f78c1104469f77ead6ec31e7b9a741e43cb8d7140f8c44b57449bd6d97e35912787cbbeee5617bdf90ce7a15ebd023721160edc06 SHA512 072a4ca8d5677e68d2893684d68d4742d7a5546e128ae99bbec0385772a5df6c885bb62b855484543a42c95471aa828f8f3375770fc079997e5183cf3eda9db8
DIST buildbot-console-view-3.5.0.tar.gz 18741 BLAKE2B a2c4043bdc9eef6189cc15617212aefd7cbdf6db6d4c547c191e0a07bacc9d0cb3e9898867af207d969b294ab15664132636dec4a3c16e620fea9872ae4d0f57 SHA512 4a86a2e803dd4547b3cc3018e1284e4fa9eaf1b29ccb78035a1823fd44fd873acb0a746882e8b961f10e8dc533043383c4a6e60622027a248c10766dab7ac266
+DIST buildbot-console-view-3.6.0.tar.gz 18728 BLAKE2B 0a206e80a311deed2666a297394b7d4e31e47c703fed2040d2d6340be0cb81a6977ac54e2d215dcad02b14ec21db58dd6e677a9d2155e84110cdf37d99ae1401 SHA512 8d03b0c640b72d986e48bc5cfd1decf91f4b7bd46889d16a76ea71972e17f9504b377762e1c589448431d7c26446c01208b5f8e1b63c86bdbfb6dbc063b94472
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-3.6.0.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-3.6.0.ebuild
new file mode 100644
index 000000000000..5b7624cd297c
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-3.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-console-view/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"