summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-10-15 00:01:36 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-18 10:05:17 +0300
commit88461ca6d3eb2ef5c1b17caa8637114163675f5d (patch)
treec37beb41fd11bc52bec50518fa98a8d4f3b6c9ed /dev-util/buildbot-wsgi-dashboards
parentdev-util/buildbot-worker: add 3.11.9 (diff)
downloadgentoo-88461ca6d3eb2ef5c1b17caa8637114163675f5d.tar.gz
gentoo-88461ca6d3eb2ef5c1b17caa8637114163675f5d.tar.bz2
gentoo-88461ca6d3eb2ef5c1b17caa8637114163675f5d.zip
dev-util/buildbot-wsgi-dashboards: add 3.11.9
Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.9.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index e6dd1f41c0e8..ae276016664d 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-wsgi-dashboards-3.11.0.tar.gz 6224 BLAKE2B 87bd27e64f5cd381a615d53e990c9723c0ebf9ae35a8fe17208a198f960a4496603bbb34394e7fda8ed8ac06f5e6b69b9dc8c813addc062b26b6d8ea6394c2ff SHA512 e361af137240282cc30e3f42214a3a71f9a829fcf409b8d908e6ab80894c1f8e91abeef2b5c9e1c8b75a8a90e1b922866b6598fce9c59649a12a1c5c2b7ed2c7
DIST buildbot-wsgi-dashboards-3.11.1.tar.gz 6222 BLAKE2B 6e07f8b410bc475166679c9453755da0398ecd1e603f552eb3928930b3de40b9620499ac40fe87c1646386b349675bd37eb539a63ea0c450ad3978fd722c9e43 SHA512 f7d905b1c16933c29366ede9fd4faf245d9563a9ff70b757f211f695aa647b8488b0353a661a18bd1e1ec33f54ffe446a0dc38c50cea59e4045b49a1803b323c
+DIST buildbot_wsgi_dashboards-3.11.9.tar.gz 6237 BLAKE2B dec0e6c4eec7e870e64b053f248b98fe4902c060b8815d8a6c4ad84f0f065132781cb8fcda71f86ddf90976719cd84cb961c6e2cc1b7252f8c2ce03e666c680a SHA512 0f98f89213f34e86f8be3e707268f30c50336f1a8bd70159d5f798c59603650c1c86fe36730607571ab92b4eae091f7fdd0b003d91b7228153938f17512441f4
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.9.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.9.ebuild
new file mode 100644
index 000000000000..3d06ce5cb569
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.11.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+PYPI_PN=${PN/-wsgi-/_wsgi_}
+inherit distutils-r1 pypi
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"