summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2019-12-22 21:30:33 -0600
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-26 17:59:29 -0800
commit43c2a717e665e94232f46379013706959207c51a (patch)
tree3d6af6c0ddb30b4965a991af9e2449d53ca2b4eb /dev-util/cargo-tree
parentdev-python/ipykernel: do not mangle the python call. (diff)
downloadgentoo-43c2a717e665e94232f46379013706959207c51a.tar.gz
gentoo-43c2a717e665e94232f46379013706959207c51a.tar.bz2
gentoo-43c2a717e665e94232f46379013706959207c51a.zip
eclass/cargo.eclass: specify --path . to install
cargo install has long required --path . for 2018 edition crates but not required it for 2015 edition crates. It is supported however for 2015 edition crates and works for all versions in the tree so it makes sense to make it the default. Added CARGO_INSTALL_PATH as an eclass variable allowing to override the default. Closes: https://bugs.gentoo.org/703590 Signed-off-by: Doug Goldstein <cardoe@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/14097 Tested-by: Georgy Yakovlev <gyakovlev@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/cargo-tree')
-rw-r--r--dev-util/cargo-tree/cargo-tree-0.23.0.ebuild2
-rw-r--r--dev-util/cargo-tree/cargo-tree-0.24.0.ebuild2
-rw-r--r--dev-util/cargo-tree/cargo-tree-0.25.0.ebuild2
-rw-r--r--dev-util/cargo-tree/cargo-tree-0.26.0.ebuild2
-rw-r--r--dev-util/cargo-tree/cargo-tree-0.27.0.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/cargo-tree/cargo-tree-0.23.0.ebuild b/dev-util/cargo-tree/cargo-tree-0.23.0.ebuild
index 360f71e835a7..52eba65bc491 100644
--- a/dev-util/cargo-tree/cargo-tree-0.23.0.ebuild
+++ b/dev-util/cargo-tree/cargo-tree-0.23.0.ebuild
@@ -184,6 +184,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_install(){
- cargo_src_install --path=.
+ cargo_src_install
einstalldocs
}
diff --git a/dev-util/cargo-tree/cargo-tree-0.24.0.ebuild b/dev-util/cargo-tree/cargo-tree-0.24.0.ebuild
index ac198d100457..131d1816df0a 100644
--- a/dev-util/cargo-tree/cargo-tree-0.24.0.ebuild
+++ b/dev-util/cargo-tree/cargo-tree-0.24.0.ebuild
@@ -176,6 +176,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_install(){
- cargo_src_install --path=.
+ cargo_src_install
einstalldocs
}
diff --git a/dev-util/cargo-tree/cargo-tree-0.25.0.ebuild b/dev-util/cargo-tree/cargo-tree-0.25.0.ebuild
index cb4b4eb835f9..c291745eb473 100644
--- a/dev-util/cargo-tree/cargo-tree-0.25.0.ebuild
+++ b/dev-util/cargo-tree/cargo-tree-0.25.0.ebuild
@@ -177,6 +177,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_install(){
- cargo_src_install --path=.
+ cargo_src_install
einstalldocs
}
diff --git a/dev-util/cargo-tree/cargo-tree-0.26.0.ebuild b/dev-util/cargo-tree/cargo-tree-0.26.0.ebuild
index 6e53a2e0be21..94af6ea62fc4 100644
--- a/dev-util/cargo-tree/cargo-tree-0.26.0.ebuild
+++ b/dev-util/cargo-tree/cargo-tree-0.26.0.ebuild
@@ -181,6 +181,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_install(){
- cargo_src_install --path=.
+ cargo_src_install
einstalldocs
}
diff --git a/dev-util/cargo-tree/cargo-tree-0.27.0.ebuild b/dev-util/cargo-tree/cargo-tree-0.27.0.ebuild
index e0917ba37b57..cdcc8337e70c 100644
--- a/dev-util/cargo-tree/cargo-tree-0.27.0.ebuild
+++ b/dev-util/cargo-tree/cargo-tree-0.27.0.ebuild
@@ -183,6 +183,6 @@ DEPEND="${RDEPEND}
"
src_install(){
- cargo_src_install --path=.
+ cargo_src_install
einstalldocs
}