summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dwarves
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dwarves')
-rw-r--r--dev-util/dwarves/Manifest1
-rw-r--r--dev-util/dwarves/dwarves-1.10_p20140618.ebuild44
-rw-r--r--dev-util/dwarves/dwarves-9999.ebuild40
-rw-r--r--dev-util/dwarves/files/dwarves-1.10-python-import.patch15
-rw-r--r--dev-util/dwarves/metadata.xml15
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-util/dwarves/Manifest b/dev-util/dwarves/Manifest
new file mode 100644
index 000000000000..501891839bd0
--- /dev/null
+++ b/dev-util/dwarves/Manifest
@@ -0,0 +1 @@
+DIST dwarves-1.10_p20140618.tar.xz 105912 SHA256 1955f854206ad26a2949fd2ff20da2403db84393fe9db5769fafcbaacde001c6 SHA512 522a6d674da5cc2316c180bcb4e90419d5811ff34e6aeeef875950dbcc4c12ea5a133d159360629d687f93ae2db622bb87d9b94a747aade90a61b239b9137a2c WHIRLPOOL 63a4ff06e76e55a0bdd1feb3c5e3c450170f3fbfae80b3d61a36e69f0616ed90e2cdbe065f47cd08caaf8de57e2ed366ded8f581eb2b228bac917b23f66f8ab8
diff --git a/dev-util/dwarves/dwarves-1.10_p20140618.ebuild b/dev-util/dwarves/dwarves-1.10_p20140618.ebuild
new file mode 100644
index 000000000000..0d0e6e763789
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.10_p20140618.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.131
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.bz2"
+ S=${WORKDIR}
+else
+ SRC_URI="http://dev.gentoo.org/~flameeyes/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${D}"/usr/bin/ostra-cg \
+ "${D}"/usr/share/dwarves/runtime/python/ostra.py
+}
diff --git a/dev-util/dwarves/dwarves-9999.ebuild b/dev-util/dwarves/dwarves-9999.ebuild
new file mode 100644
index 000000000000..115786873e8f
--- /dev/null
+++ b/dev-util/dwarves/dwarves-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/pahole/pahole.git"
+
+PYTHON_COMPAT=( python2_7 )
+inherit multilib cmake-utils git-2 python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND=">=dev-libs/elfutils-0.131
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOC=( README README.ctracer )
+
+DOCS=( README README.ctracer NEWS )
+PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${D}"/usr/bin/ostra-cg \
+ "${D}"/usr/share/dwarves/runtime/python/ostra.py
+}
diff --git a/dev-util/dwarves/files/dwarves-1.10-python-import.patch b/dev-util/dwarves/files/dwarves-1.10-python-import.patch
new file mode 100644
index 000000000000..e308ac6e2788
--- /dev/null
+++ b/dev-util/dwarves/files/dwarves-1.10-python-import.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=423817
+
+--- dwarves-1.10/ostra/ostra-cg
++++ dwarves-1.10/ostra/ostra-cg
+@@ -10,7 +10,9 @@
+ # under the terms of version 2 of the GNU General Public License as
+ # published by the Free Software Foundation.
+
+-import sys, datetime, os, ostra
++import sys
++sys.path.insert(0, "/usr/share/dwarves/runtime/python")
++import datetime, os, ostra
+
+ class_def = None
+
diff --git a/dev-util/dwarves/metadata.xml b/dev-util/dwarves/metadata.xml
new file mode 100644
index 000000000000..36b552b57152
--- /dev/null
+++ b/dev-util/dwarves/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ The more-than-seven dwarves is a collection of tools that allows
+ to inspect and query the DWARF2 information present in ELF files
+ built with full debug information. These tools include pahole
+ (Poke-a-hole) and codiff, and were originally designed to inspect
+ the Linux kernel and its modules, but can be used in for
+ user-space software too.
+ </longdescription>
+</pkgmetadata>