summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>2018-07-15 17:30:30 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-17 17:24:45 +0100
commit2ed2865794e0a21572eca83543082fcacd3117ba (patch)
tree02ecb77cabb63f3ece31736732c9a0bb6c260513 /dev-util/envman
parentdev-python/h11: Introducing new package (diff)
downloadgentoo-2ed2865794e0a21572eca83543082fcacd3117ba.tar.gz
gentoo-2ed2865794e0a21572eca83543082fcacd3117ba.tar.bz2
gentoo-2ed2865794e0a21572eca83543082fcacd3117ba.zip
dev-util/envman: new ebuild, version 1.2.0
Closes: https://github.com/gentoo/gentoo/pull/9236 Closes: https://bugs.gentoo.org/661248 Closes: https://bugs.gentoo.org/657710
Diffstat (limited to 'dev-util/envman')
-rw-r--r--dev-util/envman/Manifest1
-rw-r--r--dev-util/envman/envman-1.2.0.ebuild38
-rw-r--r--dev-util/envman/metadata.xml19
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/envman/Manifest b/dev-util/envman/Manifest
new file mode 100644
index 000000000000..e4ecaa9b6e75
--- /dev/null
+++ b/dev-util/envman/Manifest
@@ -0,0 +1 @@
+DIST envman-1.2.0.tar.gz 2997860 BLAKE2B e49d3b421fb1ab226de4430e90d8c684bc3a2554205c6383a140c0832134eaba338797dca44668fc2473d248940b5499395ab3a6d3359382305fd8a719772257 SHA512 5245aea8c280a6d6022e8132216891f09abee707c0ed736bfe6b4882aa23880a771dce5371b8ba5fcdd41fa951606727e7582442d897058b25985cf9dd5a9d18
diff --git a/dev-util/envman/envman-1.2.0.ebuild b/dev-util/envman/envman-1.2.0.ebuild
new file mode 100644
index 000000000000..6713bc5a103a
--- /dev/null
+++ b/dev-util/envman/envman-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Environment variable manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/envman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/envman || die "Couldn't compile envman"
+}
+
+src_test() {
+ GOPATH="${WORKDIR}" go test ./... || die "Tests failed"
+}
+
+src_install() {
+ dobin bin/envman
+ dodoc README.md
+}
diff --git a/dev-util/envman/metadata.xml b/dev-util/envman/metadata.xml
new file mode 100644
index 000000000000..c93a133753ba
--- /dev/null
+++ b/dev-util/envman/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>karol.wrotniak@droidsonroids.pl</email>
+ <name>Karol Wrótniak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Environment variable manager for Bitrise CLI. Part of the Bitrise Continuous Integration, Delivery and Automations Stack, with stepman and bitrise. For a nice &amp; quick intro you should check: https://www.bitrise.io/cli</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bitrise-io/envman/issues</bugs-to>
+ <changelog>https://github.com/bitrise-io/envman/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/bitrise-io/envman/blob/master/README.md</doc>
+ <remote-id type="github">bitriseio/envman</remote-id>
+ </upstream>
+</pkgmetadata>