summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/fatrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/fatrace')
-rw-r--r--dev-util/fatrace/Manifest3
-rw-r--r--dev-util/fatrace/fatrace-0.4.ebuild44
-rw-r--r--dev-util/fatrace/fatrace-0.5.ebuild35
-rw-r--r--dev-util/fatrace/fatrace-0.9.ebuild36
-rw-r--r--dev-util/fatrace/metadata.xml14
5 files changed, 132 insertions, 0 deletions
diff --git a/dev-util/fatrace/Manifest b/dev-util/fatrace/Manifest
new file mode 100644
index 000000000000..9a8124bef66a
--- /dev/null
+++ b/dev-util/fatrace/Manifest
@@ -0,0 +1,3 @@
+DIST fatrace-0.4.tar.bz2 18155 SHA256 8abd5d382610e3284f4057dc202f565ff653a5432f3bbc65463be61647e2ef94 SHA512 bd2e31a16f79127294a9599094c41043a612609241653f33fdb8adef17da99a781b5029f6b1af1731b7c939e7ae3c1d2c19f985dde72c9f409e6945d4dc1f7ce WHIRLPOOL c28337e5ca3d14b045704bb23ce386034c5a71559f8ed1a5bb471b4f4202af87088120d7e8e3de76ceae1d860b47179aceead09f277297895753c75ebfc2186e
+DIST fatrace-0.5.tar.bz2 18310 SHA256 de7e04df5650d84da9b1cecd60b0f1dade50adf7cff57835a8617bc94f2becf0 SHA512 e0357e6e74683f4d6ffaa958a704bca996823406a77b92c36537ff2bb4a47b39dd909186b0f0a5cb46672bf48d0ba64c07288d9a1f7fc83bc3928bce5bf91b2d WHIRLPOOL 0bf8ddf1370e9ab95945ed4a5df5f37c3c81e3cff7f22b05f23a86ec48507dc16541e30f58871f426624877df8afafaec3f925ed010745ef0313647bb7134efc
+DIST fatrace-0.9.tar.bz2 18828 SHA256 c028d822ffde68805e5d1f62c4e2d0f4b3d4ae565802cc9468c82b25b92e68cd SHA512 a1dbc17e1e408ddfc145e8f70580b0f5ce500fb53736d6a22547c370c4b221b362973c19a40df3c2dd911c899d74e9dc944a881eea99f9d143f6de7e213146c3 WHIRLPOOL d9b8e05cd32a9fe3904b2f1ba41ddff3e70e44610ae0f05940bb70aa54f40ed5cf6890fd6abd7b5eb4b8015a209c77e49dee6919e7afe3875a32f17f25f4ae53
diff --git a/dev-util/fatrace/fatrace-0.4.ebuild b/dev-util/fatrace/fatrace-0.4.ebuild
new file mode 100644
index 000000000000..2f6f7dc82485
--- /dev/null
+++ b/dev-util/fatrace/fatrace-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="powertop? *"
+
+inherit linux-info python toolchain-funcs
+
+DESCRIPTION="report file access events from all running processes"
+HOMEPAGE="https://launchpad.net/fatrace"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="powertop"
+
+RDEPEND="powertop? ( =sys-power/powertop-1.13 )"
+DEPEND=""
+
+CONFIG_CHECK="~FANOTIFY"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
+src_prepare() {
+ if use powertop ; then
+ sed -e "s/powertop-1.13/powertop/g" \
+ -i power-usage-report || die
+ fi
+
+ tc-export CC
+}
+
+src_install() {
+ dosbin fatrace
+ use powertop && dosbin power-usage-report
+
+ doman fatrace.1
+ dodoc NEWS
+}
diff --git a/dev-util/fatrace/fatrace-0.5.ebuild b/dev-util/fatrace/fatrace-0.5.ebuild
new file mode 100644
index 000000000000..7308375c20d8
--- /dev/null
+++ b/dev-util/fatrace/fatrace-0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit linux-info python-single-r1 toolchain-funcs
+
+DESCRIPTION="report file access events from all running processes"
+HOMEPAGE="https://launchpad.net/fatrace"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="powertop"
+
+RDEPEND="powertop? ( ${PYTHON_DEPS} )"
+DEPEND=""
+
+CONFIG_CHECK="~FANOTIFY"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin fatrace
+ use powertop && dosbin power-usage-report
+
+ doman fatrace.1
+ dodoc NEWS
+}
diff --git a/dev-util/fatrace/fatrace-0.9.ebuild b/dev-util/fatrace/fatrace-0.9.ebuild
new file mode 100644
index 000000000000..afe7c165c9ef
--- /dev/null
+++ b/dev-util/fatrace/fatrace-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit linux-info python-r1 toolchain-funcs
+
+DESCRIPTION="report file access events from all running processes"
+HOMEPAGE="https://launchpad.net/fatrace"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="powertop"
+
+RDEPEND="powertop? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="powertop? ( ${PYTHON_REQUIRED_USE} )"
+
+CONFIG_CHECK="~FANOTIFY"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin fatrace
+ use powertop && dosbin power-usage-report
+
+ doman fatrace.1
+ dodoc NEWS
+}
diff --git a/dev-util/fatrace/metadata.xml b/dev-util/fatrace/metadata.xml
new file mode 100644
index 000000000000..c4dc617de58c
--- /dev/null
+++ b/dev-util/fatrace/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <use>
+ <flag name="powertop">Add powetop integration</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">fatrace</remote-id>
+ </upstream>
+</pkgmetadata>