summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-06 07:21:04 +0000
committerSam James <sam@gentoo.org>2024-01-06 07:21:28 +0000
commit7d7e14a04b5f885578676e5d58e30a14628e6d38 (patch)
treeb20fc0926afa95b38144be4175aa9f3044f52569 /dev-util/hip
parentdev-util/hip: fix linker error for ld.lld: error: version script assignment i... (diff)
downloadgentoo-7d7e14a04b5f885578676e5d58e30a14628e6d38.tar.gz
gentoo-7d7e14a04b5f885578676e5d58e30a14628e6d38.tar.bz2
gentoo-7d7e14a04b5f885578676e5d58e30a14628e6d38.zip
dev-util/hip: apply undefined-version if linker supports it
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/hip')
-rw-r--r--dev-util/hip/hip-6.0.0.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-util/hip/hip-6.0.0.ebuild b/dev-util/hip/hip-6.0.0.ebuild
index 40efa9317ab4..a2bd451fae26 100644
--- a/dev-util/hip/hip-6.0.0.ebuild
+++ b/dev-util/hip/hip-6.0.0.ebuild
@@ -7,7 +7,7 @@ DOCS_BUILDER="doxygen"
DOCS_DEPEND="media-gfx/graphviz"
ROCM_SKIP_GLOBALS=1
-inherit cmake docs llvm rocm
+inherit cmake docs flag-o-matic llvm rocm
LLVM_MAX_SLOT=17
@@ -83,13 +83,7 @@ src_configure() {
# Fix ld.lld linker error: https://github.com/ROCm/HIP/issues/3382
# See also: https://github.com/gentoo/gentoo/pull/29097
-
- # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
- # https://github.com/gentoo/gentoo/pull/28355
- # mold needs this too but right now tc-ld-is-mold is also not available
- if tc-ld-is-lld; then
- append-ldflags -Wl,--undefined-version
- fi
+ append-ldflags $(tc-flags-CCLD -Wl,--undefined-version)
local mycmakeargs=(
-DCMAKE_PREFIX_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"